Applications not stopping correctly at shudown on wayland

Not sure if I should bother with this, or if it is something you guys want me to report…

When using wayland and shutting down the computer, applications does seem to crash. Does not happen on x11.

Summary

Feb 27 02:00:02 bednaManjaro plasmashell[1417]: qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
Feb 27 02:00:04 bednaManjaro systemd[1195]: Created slice Slice /app/dbus-:1.2-org.kde.Shutdown.
Feb 27 02:00:04 bednaManjaro systemd[1195]: Started dbus-:1.2-org.kde.Shutdown@0.service.
Feb 27 02:00:04 bednaManjaro kwin_wayland_wrapper[1325]: (EE) failed to read Wayland events: Broken pipe
Feb 27 02:00:04 bednaManjaro kaccess[1686]: The X11 connection broke (error 1). Did the X11 server die?
Feb 27 02:00:04 bednaManjaro plasmashell[1417]: file:///usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/ui/items/PlasmoidItem.qml:125: TypeError: Cannot read property 'compactRepresentation>
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-kaccess@autostart.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-kaccess@autostart.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-kaccess@autostart.service: Consumed 1.269s CPU time.
Feb 27 02:00:04 bednaManjaro kwin_wayland[1260]: QtDBus: cannot relay signals from parent QObject(0x5e72f84787f0 “”) unless they are emitted in the object’s thread QThread(0x5e72f81b7c98 “libinput-connection”). >
Feb 27 02:00:04 bednaManjaro systemd-logind[797]: The system will power off now!
Feb 27 02:00:04 bednaManjaro systemd-logind[797]: System is powering down.
Feb 27 02:00:04 bednaManjaro sddm-helper[1189]: Signal received: SIGTERM
Feb 27 02:00:04 bednaManjaro systemd[1]: Stopping Session 2 of User bedna…
Feb 27 02:00:04 bednaManjaro sddm[921]: Authentication error: SDDM::Auth::ERROR_INTERNAL “Process crashed”
Feb 27 02:00:04 bednaManjaro sddm[921]: Auth: sddm-helper (–socket /tmp/sddm-auth-ea5c1bda-485c-4960-a44e-a0323c1ca321 --id 1 --start /usr/lib/plasma-dbus-run-session-if-needed /usr/bin/startplasma-wayland --us>
Feb 27 02:00:04 bednaManjaro sddm[921]: Authentication error: SDDM::Auth::ERROR_INTERNAL “Process crashed”
Feb 27 02:00:04 bednaManjaro sddm[921]: Auth: sddm-helper exited with 1
Feb 27 02:00:04 bednaManjaro kdeconnectd[1601]: org.kde.pulseaudio: No object for name “alsa_output.pci-0000_15_00.1.hdmi-stereo”
Feb 27 02:00:04 bednaManjaro plasmashell[1417]: org.kde.plasma.pulseaudio: No object for name “alsa_output.pci-0000_15_00.1.hdmi-stereo”
Feb 27 02:00:04 bednaManjaro plasmashell[1417]: file:///usr/share/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:119: TypeError: Value is undefined and could not be converted to an object
Feb 27 02:00:04 bednaManjaro kded5[1351]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro kded5[1351]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro kactivitymanagerd[1414]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro plasmashell[1417]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro kdeconnectd[1601]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro msm_kde_notifier[1662]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro msm_kde_notifier[1662]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro xdg-desktop-portal-kde[1462]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro polkit-kde-authentication-agent-1[1460]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro pamac-tray-plasma[1690]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro yakuake[1665]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro pamac-tray-plasma[1690]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro org_kde_powerdevil[1461]: The Wayland connection broke. Did the Wayland compositor die?
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-msm_kde_notifier@autostart.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-msm_kde_notifier@autostart.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-msm_kde_notifier@autostart.service: Consumed 3.021s CPU time.
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-org.kde.yakuake@autostart.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-org.kde.yakuake@autostart.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-org.kde.yakuake@autostart.service: Consumed 2.849s CPU time.
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-xdg-desktop-portal-kde.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-xdg-desktop-portal-kde.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-polkit-agent.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-polkit-agent.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-kactivitymanagerd.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-kactivitymanagerd.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-kactivitymanagerd.service: Consumed 2.454s CPU time.
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-kded.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-kded.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-kded.service: Consumed 2.115s CPU time.
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-powerdevil.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-powerdevil.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: plasma-powerdevil.service: Consumed 2.074s CPU time.
Feb 27 02:00:04 bednaManjaro systemd[1195]: dbus-:1.2-org.kde.kdeconnect@0.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: dbus-:1.2-org.kde.kdeconnect@0.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1195]: dbus-:1.2-org.kde.kdeconnect@0.service: Consumed 1.996s CPU time.
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-pamac\x2dtray\x2dplasma@autostart.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 02:00:04 bednaManjaro systemd[1195]: app-pamac\x2dtray\x2dplasma@autostart.service: Failed with result ‘exit-code’.
Feb 27 02:00:04 bednaManjaro systemd[1]: Removed slice Slice /system/dbus-:1.2-org.kde.powerdevil.backlighthelper.

Do you guys want me to create a report or is that just a waste of time on both parts?

Ie, is this a wayland thing or a plasma thing?

System info

System:
Kernel: 6.7.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.7-x86_64
root=UUID=700d034d-b99a-482b-880b-9060acf3a6b3 rw rootflags=subvol=@
modeset=1 fbdev=1 nvidia_drm.modeset=1
resume=UUID=5ae8fbf5-a704-41ea-be6d-bf26b38325ed udev.log_priority=3
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
v: 5.115.0 wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: X670 AORUS ELITE AX v: x.x
serial: uuid: UEFI: American
Megatrends LLC. v: F20 date: 12/14/2023
CPU:
Info: model: AMD Ryzen 9 7900X bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601206
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 12 MiB desc: 12x1024 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 533 high: 3593 min/max: 400/5733 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400 14: 400
15: 400 16: 400 17: 3593 18: 400 19: 400 20: 400 21: 400 22: 400 23: 400
24: 400 bogomips: 225269
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: gather_data_sampling status: Not affected
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_rstack_overflow mitigation: Safe RET
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: eVga.com. driver: nvidia
v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
(as of 2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none empty: DP-1,
DP-2, DP-3, HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2204 class-ID: 0300
Device-2: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: HDMI-A-2 empty: DP-4,DP-5,DP-6
bus-ID: 15:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 51.0 C
Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: nvidia,amdgpu display-ID: 0
Monitor-1: HDMI-A-2 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: radeonsi x11: drv: radeonsi
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.6-manjaro1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
raphael_mendocino LLVM 16.0.6 DRM 3.57 6.7.6-1-MANJARO)
device-ID: 1002:164e memory: 500 MiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.276 layers: 9 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3090 driver: nvidia v: 550.54.14
device-ID: 10de:2204 surfaces: xcb,xlib,wayland
Audio:
Device-1: NVIDIA GA102 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 15:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 15:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.7.6-1-MANJARO status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: JACK v: 1.9.22 status: off tools: N/A
Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0e:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac:
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 0f:00.0
chip-ID: 14c3:0616 class-ID: 0280
IF: wlp15s0 state: down mac:
Info: services: NetworkManager, smbd, sshd, systemd-timesyncd
Bluetooth:
Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:5 chip-ID: 0e8d:0616
class-ID: e001 serial:
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: see --recommends
Drives:
Local Storage: total: 4.09 TiB used: 1.98 TiB (48.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: fw-rev: 5B2QGXA7 temp: 43.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 4B6Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD30EFRX-68EUZN0 size: 2.73 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial:
fw-rev: 0A80 scheme: GPT
Partition:
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 61.84 GiB (61.8%)
fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 296 KiB (0.1%) fs: vfat dev: /dev/sda5 maj-min: 8:5
ID-3: /home raw-size: 250.8 GiB size: 250.8 GiB (100.00%)
used: 140.85 GiB (56.2%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 61.84 GiB (61.8%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
Swap:
Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
compressor: zstd max-pool: 20%
ID-1: swap-1 type: partition size: 38 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda6 maj-min: 8:6
Sensors:
System Temperatures: cpu: 58.0 C mobo: 44.0 C gpu: amdgpu temp: 53.0 C
Fan Speeds (rpm): N/A
Info:
Memory: total: 32 GiB note: est. available: 30.5 GiB used: 5.17 GiB (16.9%)
Processes: 501 Power: uptime: 56m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.15 GiB services: org_kde_powerdevil,upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: 1618 pm: pacman pkgs: 1605 libs: 445 tools: pamac,yay pm: flatpak
pkgs: 13 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
v: 5.2.26 running-in: yakuake inxi: 3.3.33

It is plasma, but maybe it does not matter, since kde 6 is out soon.

But if I use cli (a normal graphical terminal, in my case yakuake, not tty) to turn off the computer, sudo shutdown now, it works flawlessly, but if I use the “shut down” button on the “start menu”, screen immediately turns black and all the applications shown in the log crashes at shutdown.

And I do not mean “waiting for xxx to stop”, I mean completely disregard anything and the computer shuts off in 1second.

It is a bug, but I wont report it since interest does not seem to exist.