At Installation Digikam can't select folder with photos

At Installation of Digikam 8.1 - 1st step is to select the location where the images are to be kept.
In my case the correct (already existing) folder is /home/mik-b/photos.
Problem is that DK does not “see” that the folder exists. The only option, even with browsing, is /home/mik-b/Pictures. I don’t want to change the location.

Trying to figure out how to word this.

You are running a KDE Plasma application on Gnome. Gnome uses the GTK framework and the GTK File Picker. Digikam uses the QT framework and QT File Picker. There are missing QT Framework files that you need. You can run applications on either system, but these frameworks are critical.

NOTE: The frameworks will not show as dependencies of the application. These are dependencies of the desktop environment. If I knew which files you need, I would tell you just what you need to install, but this is a bit out of my realm of experience. I have managed to do this with Kate on Gnome in the past, but I don’t remember what files I needed. It did take a bit of work to run it all down and quite a lot of running the application from the command line to see what it couldn’t find.

I am looking at the list of files in my system and your distro might have a different name for the same files. These are also just guesses. These may or may not work for you and if they do work, may only be the beginning of a deeper rabbit hole. :joy:


Please remember that the folks over at Gnome don’t care if you ever get a KDE program to run on their system. The words Cross Platform are not in their vocabulary.

Did you install the app via Flatpak? I see that Digikam’s Flatpak manifest file only grants access to ~/Pictures by default; see

If so, that could explain why only /home/mik-b/Pictures is visible there. You can fix this by installing the Flatseal app and using it to give Digikam access to the entire home folder.

I’m struggling to understand why the app doesn’t come pre-packaged that way, though. With my user hat on, I’d even consider it a bug, given that Digikam is a library manager app and not having access to all the places your photo library might live doesn’t make sense. And in fact, there’s already an issue on FlatHub tracking this: Default permissions · Issue #3 · flathub/org.kde.digikam · GitHub

1 Like

Regardless of whether this is exactly your issue or not, I decided to send a pull request to fix the default Flathub permissions, since they felt wrong to me.

1 Like

I used to run DK v4 quite happily on Fedora.

  • The plasma-framework bits that you cite are not on the system as-is
  • There are 3 options here.
    1. use the installed flatpack setup and hope that the change requested by Nate come through quickly.

    2. The text in DK states that further sources can be added after the initial setup. Based on that, go with a setup for /pictures and then subsequently add the correct folder

    3. uninstall flatpack version and then try command line install using the Fedora source so as to see which error messages are listed. (I guess that the messages from the previous try might be in a log somewhere but I’ve no idea where to look)

I HAVE installed the KDE desktop which might perhaps solve the issues of using a (very good) KDE app. DK works just fine now.
Thanks for your help and advice.

Nate, Installed flatseal
Selected "Filesystem, All User Files, filesystem=home

DK appears to be working perfectly

Thank you

1 Like

Not sure if this is the right place to post, but I’m running the AppImage version of DigiKam, and it looks like I have the GTK file picker. Is there any way to swith this to Dolphin?

I’m running MX 23 , KDE version.