AVI import - video ok but audio sounds like mickey mouse

I have imported an avi into kdenlive having set the video project to the avi video format. When I play the sequence the video is ok but the audio is pitched up.
Windows properties and VLC think the audio sample rate is 32000 kHz. kdenlive thinks it is 48000 kHz which I guess is altering the audio pitch. I can’t see anywhere in kdenlive to change the sample rate.
I have also tried accepting the option where kdenlive asks if I want to adopt the avi format but same result.

Hello @Richard, welcome to the forum.
It’s hard to predict what’s wrong. If it’s possible for you, can you upload the avi clip so I can have a look?

Hi, thanks for the reply. I have managed to transcode the video using ffmpeg.
I suspect it’s a bug in kdenlive. There doesn’t seem to be an option to change the audio sample rate, I think it just defaults to 48000kHz even though the imported audio is 32000kHz.