Blocked executable in the ESP, ensure grub and shim are up to date: No ESP or BDP found

I 'm getting this error when updating KDE NEon - ANy idea on how to solve it?

1 Like

Same here, I just upgraded Neon two days ago, and it keeps saying that I need to reboot the computer, apparently because it fails to update UEFI dbx

this seems to be resolved in today’s updates

Not here. I still see the error: Blocked executable in the ESP, ensure grub and shim are up to date: No ESP or BDP found

indeed, it’s just partially “solved”: the tray icon does not force you to reboot anymore, but the error still shows when trying to update