Can run kdenlive on Buster but not on Bullseye in a RPi4B4GB

I can load and run kdenlive on Buster but not on Bullseye in a RPi4B4GB. Why?

No. Do you have tried with the AppImage? Kdenlive runs on 64bit only. BTW: Latest Debian is Bookworm.