Can't install wine32 in kde neon

Reading package lists…
Building dependency tree…
Reading state information…
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
grub-common : Depends: libfreetype6 (>= 2.2.1) but it is not installable
Recommends: os-prober (>= 1.33) but it is not going to be installed
neon-desktop : Depends: baloo-kf5 but it is not going to be installed
Depends: breeze but it is not going to be installed
Depends: distro-release-notifier but it is not going to be installed
Depends: ghostscript-x but it is not going to be installed
Depends: kde-cli-tools but it is not going to be installed
Depends: khotkeys but it is not going to be installed
Depends: kinfocenter but it is not going to be installed
Depends: kio but it is not going to be installed
Depends: kio-extras but it is not going to be installed
Depends: kmenuedit but it is not going to be installed
Depends: kwin-wayland but it is not going to be installed
Depends: kwin-x11 but it is not going to be installed
Depends: kwrited but it is not going to be installed
Depends: powerdevil but it is not going to be installed
Depends: printer-driver-pnm2ppa but it is not going to be installed
Depends: sddm-theme-breeze but it is not going to be installed
Depends: spice-vdagent but it is not going to be installed
Depends: systemsettings but it is not going to be installed
Depends: ubuntu-release-upgrader-qt but it is not going to be installed
Depends: xorg but it is not going to be installed
Recommends: ark but it is not going to be installed
Recommends: bluedevil but it is not going to be installed
Recommends: bluez-cups but it is not going to be installed
Recommends: cups but it is not going to be installed
Recommends: cups-filters but it is not going to be installed
Recommends: curl
Recommends: dolphin but it is not going to be installed
Recommends: dolphin-plugins but it is not going to be installed
Recommends: drkonqi-pk-debug-installer but it is not going to be installed
Recommends: ffmpegthumbs but it is not going to be installed
Recommends: firefox but it is not going to be installed
Recommends: flatpak-kcm but it is not going to be installed
Recommends: frameworkintegration but it is not going to be installed
Recommends: fwupd-signed but it is not going to be installed
Recommends: gwenview but it is not going to be installed
Recommends: hplip but it is not going to be installed
Recommends: kde-config-gtk-style but it is not going to be installed
Recommends: kde-config-gtk-style-preview but it is not going to be installed
Recommends: kde-config-plymouth but it is not going to be installed
Recommends: kde-config-sddm but it is not going to be installed
Recommends: kde-inotify-survey but it is not going to be installed
Recommends: kde-nomodeset but it is not going to be installed
Recommends: kde-spectacle but it is not going to be installed
Recommends: kdeconnect but it is not going to be installed
Recommends: kdegraphics-thumbnailers but it is not going to be installed
Recommends: kdialog but it is not going to be installed
Recommends: kimageformat-plugins but it is not going to be installed
Recommends: kio-admin but it is not going to be installed
Recommends: kio-fuse but it is not going to be installed
Recommends: kio-gdrive but it is not going to be installed
Recommends: konsole but it is not going to be installed
Recommends: kscreen but it is not going to be installed
Recommends: ksshaskpass but it is not going to be installed
Recommends: kwin-addons but it is not going to be installed
Recommends: kwrite but it is not going to be installed
Recommends: libappimage0 but it is not going to be installed
Recommends: milou but it is not going to be installed
Recommends: okular but it is not going to be installed
Recommends: phonon4qt5-backend-vlc but it is not going to be installed
Recommends: plasma-browser-integration but it is not going to be installed
Recommends: plasma-calendar-addons but it is not going to be installed
Recommends: plasma-dataengines-addons but it is not going to be installed
Recommends: plasma-discover but it is not going to be installed
Recommends: plasma-disks but it is not going to be installed
Recommends: plasma-firewall but it is not going to be installed
Recommends: plasma-nm but it is not going to be installed
Recommends: plasma-pa but it is not going to be installed
Recommends: plasma-runners-addons but it is not going to be installed
Recommends: plasma-systemmonitor but it is not going to be installed
Recommends: plasma-thunderbolt but it is not going to be installed
Recommends: plasma-vault but it is not going to be installed
Recommends: plasma-wallpapers-addons but it is not going to be installed
Recommends: plasma-welcome but it is not going to be installed
Recommends: plasma-widgets-addons but it is not going to be installed
Recommends: plasma-workspace-wayland but it is not going to be installed
Recommends: plymouth-theme-breeze but it is not going to be installed
Recommends: polkit-kde-agent-1 but it is not going to be installed
Recommends: print-manager but it is not going to be installed
Recommends: printer-driver-c2esp but it is not going to be installed
Recommends: printer-driver-foo2zjs but it is not going to be installed
Recommends: printer-driver-m2300w but it is not going to be installed
Recommends: printer-driver-ptouch but it is not going to be installed
Recommends: printer-driver-sag-gdi but it is not going to be installed
Recommends: printer-driver-splix but it is not going to be installed
Recommends: qml-module-qtgraphicaleffects but it is not going to be installed
Recommends: qt5-image-formats-plugins but it is not going to be installed
Recommends: vlc but it is not going to be installed
plasma-desktop : Depends: baloo-kf5 but it is not going to be installed
Depends: breeze (>= 4:5.14) but it is not going to be installed
Depends: ibus-data but it is not going to be installed
Depends: kactivitymanagerd (>= 5.14) but it is not going to be installed
Depends: kde-cli-tools (>= 4:5.14) but it is not going to be installed
Depends: kded5 but it is not going to be installed
Depends: kio but it is not going to be installed
Depends: plasma-framework but it is not going to be installed
Depends: plasma-integration (>= 5.14) but it is not going to be installed
Depends: plasma-thunderbolt but it is not going to be installed
Depends: plasma-workspace (>= 4:5.14) but it is not going to be installed
Depends: polkit-kde-agent-1 (>= 4:5.14) but it is not going to be installed
Depends: qml-module-org-kde-draganddrop but it is not going to be installed
Depends: qml-module-org-kde-kcoreaddons but it is not going to be installed
Depends: qml-module-org-kde-kirigami2 (>= 5.54.0~) but it is not going to be installed
Depends: qml-module-org-kde-kquickcontrols but it is not going to be installed
Depends: qml-module-org-kde-kquickcontrolsaddons but it is not going to be installed
Depends: qml-module-org-kde-kwindowsystem but it is not going to be installed
Depends: qml-module-org-kde-pipewire but it is not going to be installed
Depends: qml-module-org-kde-solid but it is not going to be installed
Depends: qml-module-qt-labs-platform but it is not going to be installed
Depends: libkaccounts2 but it is not going to be installed
Depends: libkf5authcore5 but it is not going to be installed
Depends: libkf5baloo5 but it is not going to be installed
Depends: libkf5bookmarks5 but it is not going to be installed
Depends: libkf5completion5 but it is not going to be installed
Depends: libkf5configgui5 but it is not going to be installed
Depends: libkf5configwidgets5 but it is not going to be installed
Depends: libkf5crash5 but it is not going to be installed
Depends: libkf5dbusaddons5 but it is not going to be installed
Depends: libkf5globalaccel5 but it is not going to be installed
Depends: libkf5guiaddons5 (>= 5.107.0) but it is not going to be installed
Depends: libkf5iconthemes5 but it is not going to be installed
Depends: libkf5itemviews5 but it is not going to be installed
Depends: libkf5jobwidgets5 but it is not going to be installed
Depends: libkf5kcmutils5 but it is not going to be installed
Depends: libkf5kcmutilscore5 but it is not going to be installed
Depends: libkf5kdelibs4support5 but it is not going to be installed
Depends: libkf5kiocore5 but it is not going to be installed
Depends: libkf5kiofilewidgets5 but it is not going to be installed
Depends: libkf5kiogui5 but it is not going to be installed
Depends: libkf5kiowidgets5 but it is not going to be installed
Depends: libkf5newstuffcore5 but it is not going to be installed
Depends: libkf5notifications5 but it is not going to be installed
Depends: libkf5notifyconfig5 but it is not going to be installed
Depends: libkf5plasma5 (>= 5.107.0) but it is not going to be installed
Depends: libkf5plasmaquick5 (>= 5.107.0) but it is not going to be installed
Depends: libkf5quickaddons5 but it is not going to be installed
Depends: libkf5runner5 but it is not going to be installed
Depends: libkf5service5 but it is not going to be installed
Depends: libkf5solid5 but it is not going to be installed
Depends: libkf5sonnetui5 but it is not going to be installed
Depends: libkf5widgetsaddons5 but it is not going to be installed
Depends: libkf5windowsystem5 (>= 5.107.0) but it is not going to be installed
Depends: libkf5xmlgui5 but it is not going to be installed
Depends: libkworkspace5-5 but it is not going to be installed
Depends: libnotificationmanager1 but it is not going to be installed
Depends: libphonon4qt5-4 (>= 4:4.11.1) but it is not going to be installed
Depends: libprocesscore9 but it is not going to be installed
Depends: libqt5gui5 (>= 5.15.10+p22.04+tunstable+git20230614.1257) but it is not going to be installed
Depends: libqt5quick5 (>= 5.15.10+p22.04+tunstable+git20230615.0109) but it is not going to be installed
Depends: libqt5quickwidgets5 (>= 5.15.10+p22.04+tunstable+git20230615.0109) but it is not going to be installed
Depends: libqt5waylandclient5 (>= 5.15.10+p22.04+tunstable+git20230615.0746) but it is not going to be installed
Depends: libqt5widgets5 (>= 5.15.10+p22.04+tunstable+git20230614.1257) but it is not going to be installed
Depends: libqt5x11extras5 (>= 5.15.10+p22.04+tunstable+git20230615.0746) but it is not going to be installed
Depends: libscim8v5 (>= 1.4) but it is not going to be installed
Depends: libtaskmanager6 but it is not going to be installed
Depends: phonon4qt5 but it is not going to be installed
Recommends: bluedevil (>= 4:5.14) but it is not going to be installed
Recommends: breeze-gtk-theme (>= 5.14) but it is not going to be installed
Recommends: kde-config-gtk-style (>= 4:5.14) but it is not going to be installed
Recommends: kde-config-screenlocker (>= 5.14) but it is not going to be installed
Recommends: kde-config-sddm (>= 4:5.14) but it is not going to be installed
Recommends: kde-style-oxygen-qt5 (>= 4:5.14) but it is not going to be installed
Recommends: kgamma5 (>= 5.14) but it is not going to be installed
Recommends: khelpcenter but it is not going to be installed
Recommends: khotkeys (>= 4:5.14) but it is not going to be installed
Recommends: kinfocenter (>= 4:5.14) but it is not going to be installed
Recommends: kio-extras but it is not going to be installed
Recommends: kmenuedit (>= 4:5.14) but it is not going to be installed
Recommends: kscreen (>= 4:5.14) but it is not going to be installed
Recommends: ksshaskpass (>= 4:5.14) but it is not going to be installed
Recommends: kwin-x11 (>= 4:5.14) but it is not going to be installed or
kwin
Recommends: kwrited (>= 4:5.14) but it is not going to be installed
Recommends: plasma-discover (>= 5.14) but it is not going to be installed
Recommends: plasma-pa (>= 4:5.14) but it is not going to be installed
Recommends: powerdevil (>= 4:5.14) but it is not going to be installed
Recommends: systemsettings (>= 4:5.14) but it is not going to be installed
sddm : Depends: qml-module-qtquick2 but it is not going to be installed
Depends: xserver-xorg but it is not going to be installed or
xserver
Depends: libqt5gui5 (>= 5.15.10+p22.04+tunstable+git20230717.0137) but it is not going to be installed
Depends: libqt5quick5 (>= 5.15.10+p22.04+tunstable+git20230707.0121) but it is not going to be installed
Recommends: sddm-theme-debian-breeze but it is not installable or
sddm-theme

#default wine will be 64bit and will not run 32bit apps very well (if at all)
#to create a 32bit wine environment use a WINEPREFIX to create a separate directory
WINEPREFIX=~/.wine32 WINEARCH="win32" winecfg

#then to run a 32bit program, specify the prefix when starting the program
WINEPREFIX=~/.wine32 wine $HOME'/.wine32/drive_c/Program Files (x86)/32bit/example32.exe'

it looks like wine32 is missing, you should install it.
as root, please execute “apt-get install wine32”

but i cant install wine32

bogdan@bogdan-Phenom2:~$ WINEPREFIX=~/.wine32 WINEARCH=“win32” winecfg
it looks like wine32 is missing, you should install it.
as root, please execute “apt-get install wine32”
wine: ‘/home/bogdan/.wine32’ is a 32-bit installation, it cannot support 64-bit applications.
bogdan@bogdan-Phenom2:~$

try dpkg --print-foreign-architectures

and see what it gives you.

it should say

i386

if not then you need to install support for it with

sudo dpkg --add-architecture i386

here’s a whole article on it.

sudo dpkg --add-architecture i386
says i386
i tried install winehq from wine.htmlvalidator.com article but always the same. it wants wine32 but i cant install it

First off, the page you should be using is this: KDE neon – How to Install Wine on KDE neon based on Ubuntu 22.04

Your link is for kubuntu 20.04, but current KDE Neon is based on 22.04, and the site has special pages for Neon anyway.

Second, the problem is that the developers have stopped making 32-bit binaries entirely, even for software that may need it, like Wine. I’m not sure if this is the KDE Neon developers, or the (K)Ubuntu developers.
The page linked above gets around that issue by providing their own binaries from a PPA. This worked well until recently.

However, a few days ago some packages in the Ubuntu 22.04 repositories got updated with new versions and they’re no longer compatible with the wine32 package from that PPA.
That means you can’t install wine32 from there if you start now, and if you already had (like in my case) then you can’t update those packages without uninstalling it.

The only options now are basically

  1. See if the PPA will update its wine32 package (they haven’t yet)
  2. Find another PPA that provides a more up-to-date package (I’ve not found one yet)
  3. Compile the 32 binaries manually (not easy, so I’m personally holding off for now)

EDIT: Updated my link to a Neon-specific page

1 Like

good info, that means i can’t (re)install it on kubutu either until the PPA is updated.

tracking this post to watch for updates

in the meantime there is bottles, i suppose

I’ve looked into it a bit more, and it’s more complicated than I thought. At least if I understand correctly. (tl;dr at the bottom)

Ubuntu has updated the libpoppler-glib8 package, from 22.02.0-2ubuntu0.1 to 22.02.0-2ubuntu0.2 and Wine is fine with this as far as I can tell.

The issue is that KDE Neon has further updated the same package, to 23.04.0-0xneon+22.04+jammy+release+build14 and as they don’t provide 32-bit packages, this version cannot be used with wine32. This is likely specifically why the guide for KDE Neon has you install an “older” version of the package manually.

That older version doesn’t exist now since Ubuntu updated it, and that may be why following the guide fails. But if we just install the newer one from Ubuntu, not from KDE Neon, I think it should still work. At least in my case it made it stop complaining about updates.

tl;dr
@Bogkuz : Please try following the guide from this link, assuming your KDE Neon is fully updated.: KDE neon – How to Install Wine on KDE neon based on Ubuntu 22.04
When you get to the part where it says to run

sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.1

run the following instead (same thing, but with the last 1 replaced by 2:

sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.2

See if this allows you to install the package.

1 Like

apt can’t install this package (

bogdan@bogdan-Phenom2:~$ sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.2
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Starting pkgProblemResolver with broken count: 5
Starting 2 pkgProblemResolver with broken count: 5
Investigating (0) libpoppler-glib8:i386 < none → 22.02.0-2ubuntu0.2 @un puN Ib >
Broken libpoppler-glib8:i386 Depends on libfreetype6:i386 < none @un pH > (>= 2.2.1)
Considering libfreetype6:i386 0 as a solution to libpoppler-glib8:i386 9999
Considering libfreetype6:i386 0 as a solution to libpoppler-glib8:i386 9999
Investigating (0) libfontconfig1:i386 < none → 2.13.1-4.2ubuntu5 @un puN Ib >
Broken libfontconfig1:i386 Depends on libfreetype6:i386 < none @un pH > (>= 2.9.1)
Considering libfreetype6:i386 0 as a solution to libfontconfig1:i386 1
Considering libfreetype6:i386 0 as a solution to libfontconfig1:i386 1
Investigating (0) libpoppler118:i386 < none → 22.02.0-2ubuntu0.2 @un puN Ib >
Broken libpoppler118:i386 Depends on libfreetype6:i386 < none @un pH > (>= 2.2.1)
Considering libfreetype6:i386 0 as a solution to libpoppler118:i386 0
Considering libfreetype6:i386 0 as a solution to libpoppler118:i386 0
Investigating (0) libcairo2:i386 < none → 1.16.0-5ubuntu2 @un puN Ib >
Broken libcairo2:i386 Depends on libfreetype6:i386 < none @un pH > (>= 2.9.1)
Considering libfreetype6:i386 0 as a solution to libcairo2:i386 0
Considering libfreetype6:i386 0 as a solution to libcairo2:i386 0
Investigating (0) libtiff5:i386 < none → 4.3.0-6ubuntu0.5 @un puN Ib >
Broken libtiff5:i386 Depends on libwebp7:i386 < none @un pH >
Considering libwebp7:i386 1 as a solution to libtiff5:i386 0
Considering libwebp7:i386 1 as a solution to libtiff5:i386 0
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libcairo2:i386 : Depends: libfreetype6:i386 (>= 2.9.1) but it is not installable
libfontconfig1:i386 : Depends: libfreetype6:i386 (>= 2.9.1) but it is not installable
libpoppler-glib8:i386 : Depends: libfreetype6:i386 (>= 2.2.1) but it is not installable
libpoppler118:i386 : Depends: libfreetype6:i386 (>= 2.2.1) but it is not installable
libtiff5:i386 : Depends: libwebp7:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

Does anyone have any new information on this matter?

Solved!
I’ve asked to David Bridges, the author of this page and he solved the problem.

Use this command:
$ sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.3

Simply substituting the last “2” with “3”.

Many thanks to David.

Thank you for respnse.

bogdan@bogdan-Phenom2:~$ sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.3
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Starting pkgProblemResolver with broken count: 5
Starting 2 pkgProblemResolver with broken count: 5
Investigating (0) libpoppler-glib8:i386 < none → 22.02.0-2ubuntu0.3 @un puN Ib >
Broken libpoppler-glib8:i386 Depends on libfreetype6:i386 < none @un pH > (>= 2.2.1)
Considering libfreetype6:i386 0 as a solution to libpoppler-glib8:i386 9999
Considering libfreetype6:i386 0 as a solution to libpoppler-glib8:i386 9999
Investigating (0) libfontconfig1:i386 < none → 2.13.1-4.2ubuntu5 @un puN Ib >
Broken libfontconfig1:i386 Depends on libfreetype6:i386 < none @un pH > (>= 2.9.1)
Considering libfreetype6:i386 0 as a solution to libfontconfig1:i386 1
Considering libfreetype6:i386 0 as a solution to libfontconfig1:i386 1
Investigating (0) libpoppler118:i386 < none → 22.02.0-2ubuntu0.3 @un puN Ib >
Broken libpoppler118:i386 Depends on libfreetype6:i386 < none @un pH > (>= 2.2.1)
Considering libfreetype6:i386 0 as a solution to libpoppler118:i386 0
Considering libfreetype6:i386 0 as a solution to libpoppler118:i386 0
Investigating (0) libcairo2:i386 < none → 1.16.0-5ubuntu2 @un puN Ib >
Broken libcairo2:i386 Depends on libfreetype6:i386 < none @un pH > (>= 2.9.1)
Considering libfreetype6:i386 0 as a solution to libcairo2:i386 0
Considering libfreetype6:i386 0 as a solution to libcairo2:i386 0
Investigating (0) libtiff5:i386 < none → 4.3.0-6ubuntu0.7 @un puN Ib >
Broken libtiff5:i386 Depends on libwebp7:i386 < none @un pH >
Considering libwebp7:i386 1 as a solution to libtiff5:i386 0
Considering libwebp7:i386 1 as a solution to libtiff5:i386 0
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libcairo2:i386 : Depends: libfreetype6:i386 (>= 2.9.1) but it is not installable
libfontconfig1:i386 : Depends: libfreetype6:i386 (>= 2.9.1) but it is not installable
libpoppler-glib8:i386 : Depends: libfreetype6:i386 (>= 2.2.1) but it is not installable
libpoppler118:i386 : Depends: libfreetype6:i386 (>= 2.2.1) but it is not installable
libtiff5:i386 : Depends: libwebp7:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

Strange, I’ve installed without any problem.
Have you updated Neon?
I have done the work on a new installation, so it can be it require an up to date system.

My system is up to dated. Mayby I must freshly reinstall my system.