Clearing and/or Editing Memo field in KMyMoney

I am a rank beginner running Linux v. 5.1.3 of KMyMoney.

How can I access the Memo field to edit it other than on a transaction by transaction basis?

How can I search the Memo field?

How can I clear en masse the Memo field of all transactions having something in it? I couldn’t find anything online or in the handbook to help so far.

If you are using 5.1.3, then you can select multiple transactions in the ledger - either Ctl-Click on each one, or click on the first and then Shift-Click on the last of a range. You should then be able to edit all the transactions at once. However, nothing will appear in the memo box of the transaction editor because the transactions have different values in that field. So, you can enter for example “X” and accept the change, then edit again, and delete the X. I don’t remember for sure, but it is possible that not every transaction can be edited with any other, so if “Edit” is disabled, try selecting fewer transactions.
You can enter the text you want to search for either in the serach box below the ledger or in the Search dialog, and it will look for that text in the memo - as well as in other fields - so be careful to select only the transactions you actually want to edit.

That’s close enough for government work, as the saying goes. :wink: Thanks!

BTW, all transactions can be selected using Ctrl+A

Sorry to be such a pain, but when I tried it, KMyMoney would not allow me to edit multiple split transactions at once.

As a kludge, by searching for a particular payee, copying the Memo that appears there, going back to the Ledgers and searching for it, I am able to edit only the Memo field in those transactions. That will get me along (I imported some 1,700 transactions to set up KMyMoney), but it’s slow. :man_shrugging:

Sorry, but editing multiple split transactions is not supported.