Flatpak GTK apps not follwing the chosen GTK theme

Hello. I’m using Debian testing with KDE Plasma 5.27. I’m experiencing a problem where GTK Flatpaks are not following the chosen GTK theme despite giving them permissions to access .themes and .icons folders found in the home directory. I tried the running the following commands in the terminal:

flatpak override --filesystem=xdg-config/gtk-4.0:ro flatpak override --filesystem=xdg-config/gtk-3.0:ro
I also tried installing the xdg-desktop-portal-gtk package, but it was already installed.
I even tried to specify a certain GTK theme to be chosen, that resulted in the flatpak changing to an ugly white-adwaita theme.
I should note that this is happening exclusively with GTK Flatpaks, QT Flatpaks and GTK deb packages don’t seem to have this problem. What am I missing here? Any help would be appreciated.

Edit: I just tried completly wiping out kde plasma from the system and then reinstalling it, that didn’t seem to work either.

Assuming you aren’t comparing the same app, just with Flatpak instead of native. If so, it’s something else.

But are you sure the apps you’re talking about aren’t using libadwaita? Those apps have a hardcoded stylesheet, and modifying them is a different process that doesn’t work using the classic GTK theme system.

Not saying that’s definitely it, but if the app has this design language, it’s using libadwaita (or something similar, same principle) so it won’t follow your system theme anyway.

1 Like

Can GIMP installed from Flatpack be made beautiful using the Breeze theme?