Graphics error in desktop, help appreciated

I am on kubuntu 24 kde plasma.

Started using linux around the beginning of June. it took me a long time to figure out how to replicate this. In the video below, I start by moving the cursor around to show normal behavior … text is readable, no visual glitches. The I start Factorio and exit the game. The visual problems are apparent, blurry text which pulses oddly.

This is where the link to the youtube video should go, but the forum is not letting me post links or upload the video. Can someone please tell me how to show the video? youtube. com/watch?v=R2dfpO1sPCQ

As far as I can tell, the only fix is a full reboot (log in screen does not do it.)

Exiting fullscreen Factorio appears to cause the problem every time, but it is not the only game that does this. AND Factorio only causes the problem when it is in full screen, I tested it out a couple times by putting it in windowed mode first and the glitch did not happen. Sometimes I get a full system lockup as well, which locks out everything but the meta key on the keyboard.

It has happened when games are not involved. Once I noticed it happened when switching out of Alt+Ctrl+F3 and back to F2.

So my uneducated guess is that it is somehow related to fullscreen applications switching back to regular desktop mode. I tried turning off compositor at startup, but that didn’t seem to help. I also tried running steam in both native and flatpak and it gave the same error either way.

I am sorry for not posting error logs … I don’t really know where they are yet. Please let me know a command if you would like me to post one.

I don’t know if this is a bug that needs reporting or some other issue so I hope it is ok to post here first

Thanks for any advice :slight_smile:

specs

 inxi -b
System:
  Host: Home Kernel: 6.8.0-36-generic arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 5.27.11 Distro: Kubuntu 24.04 LTS (Noble Numbat)
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME X670E-PRO WIFI v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 1813
    date: 10/13/2023
CPU:
  Info: 6-core AMD Ryzen 5 7600X [MT MCP] speed (MHz): avg: 2404
    min/max: 400/5453
Graphics:
  Device-1: NVIDIA AD104 [GeForce RTX 4070 Ti] driver: nvidia v: 535.183.01
  Device-2: AMD Raphael driver: amdgpu v: kernel
  Display: x11 server: X .Org v: 21.1.11 with: Xwayland v: 23.2.6 driver: X:
    loaded: amdgpu,modesetting,nouveau,nvidia unloaded: fbdev,vesa dri: radeonsi
    gpu: nvidia,nvidia-nvswitch resolution: 1: 2560x1440 2: 1920x1080~60Hz
    3: N/A
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 535.183.01
    renderer: NVIDIA GeForce RTX 4070 Ti/PCIe/SSE2
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  Device-2: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e
Drives:
  Local Storage: total: 33.67 TiB used: 21.25 TiB (63.1%)
Info:
  Memory: total: 32 GiB note: est. available: 30.56 GiB used: 4.04 GiB (13.2%)
  Processes: 329 Uptime: 8m Shell: Bash inxi: 3.3.34



nvidia-smi
Wed Jul 10 02:45:28 2024       
+---------------------------------------------------------------------------------------+
| NVIDIA-SMI 535.183.01             Driver Version: 535.183.01   CUDA Version: 12.2     |
|-----------------------------------------+----------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|=========================================+======================+======================|
|   0  NVIDIA GeForce RTX 4070 Ti     Off | 00000000:01:00.0  On |                  N/A |
|  0%   33C    P8               9W / 285W |    755MiB / 12282MiB |      0%      Default |
|                                         |                      |                  N/A |
+-----------------------------------------+----------------------+----------------------+
                                                                                         
+---------------------------------------------------------------------------------------+
| Processes:                                                                            |
|  GPU   GI   CI        PID   Type   Process name                            GPU Memory |
|        ID   ID                                                             Usage      |
|=======================================================================================|
|    0   N/A  N/A      1723      G   /usr/lib/xorg/Xorg                          245MiB |
|    0   N/A  N/A      1984      G   /usr/bin/kwalletd5                            3MiB |
|    0   N/A  N/A      2193      G   /usr/bin/ksmserver                            3MiB |
|    0   N/A  N/A      2195      G   /usr/bin/kded5                                3MiB |
|    0   N/A  N/A      2196      G   /usr/bin/kwin_x11                            24MiB |
|    0   N/A  N/A      2238      G   /usr/bin/plasmashell                         66MiB |
|    0   N/A  N/A      2262      G   ...c/polkit-kde-authentication-agent-1        3MiB |
|    0   N/A  N/A      2264      G   ...-gnu/libexec/xdg-desktop-portal-kde        3MiB |
|    0   N/A  N/A      2395      G   ...86_64-linux-gnu/libexec/kdeconnectd        3MiB |
|    0   N/A  N/A      2420      G   /usr/bin/kaccess                              3MiB |
|    0   N/A  N/A      2425      G   ...-linux-gnu/libexec/DiscoverNotifier        3MiB |
|    0   N/A  N/A      2445      G   ...irefox/4483/usr/lib/firefox/firefox      303MiB |
|    0   N/A  N/A      2489      G   /usr/bin/dolphin                              3MiB |
|    0   N/A  N/A      2567      G   /usr/bin/kate                                 3MiB |
|    0   N/A  N/A      8641      G   ...bian-installation/ubuntu12_32/steam        3MiB |
|    0   N/A  N/A      8841      G   ./steamwebhelper                              8MiB |
|    0   N/A  N/A     12369      G   /usr/bin/dolphin                              3MiB |
|    0   N/A  N/A     14312      G   /usr/bin/konsole                              3MiB |
+---------------------------------------------------------------------------------------+`

We are now starting to see the shift over to wayland more and more, so waiting for a fix on x11 is probably not a great idea.
I do not know how kubuntu is handling this, but my suggestion is start using wayland.

If windowed mode works, just use it in borderless window.
Also, what you could play around with instead of changing the steam version (that should not matter) change the compatibility layer you use.
Factoria has a native linux client, and I do not know what version you are running. Could be worth switching back and forth between those and see if there is any difference.

You are on the 535 drivers, witch to me was stable on wayland when I was using it.

There is a lot of stuff in there, not sure why.
Having both nouveau AND the nvidia driver is probably also not a good idea.
I think all you need is modesetting and nvidia in there. Your amd is baked into the kernel so if you run things off that it should “just work”.

Factoria has a native linux client, and I do not know what version you are running.

Factorio won’t run in compatibility mode, so it is running in native linux mode. But as I mentioned, the problem can happen even when games are not involved.

There is a lot of stuff in there, not sure why.
Having both nouveau AND the nvidia driver is probably also not a good idea.

I am new and don’t understand any of how linux deals with video. How can I set it so only the nvidia driver is active? The amd is probably the onboard video which is not going to be great.

Also, I never set wayland as the default, I thought it was still on x11 default. So I don’t know what to do. How can I tell if it is using wayland or x11?

I don’t know about kbuntu, probably by uninstalling nouveau.
Might be better to ask on their forums, or maybe someone else can chime in.

If you use sddm there is a package, I think… And it will add a dropdown at login where you can select, but again, kubuntu might do things differently.
Maybe you don’t even have wayland installed. (you probably do, because xwayland is there)

You see that you use x11 in your inxi output:

I never installed wayland … I don’t know if it comes with kubuntu or any other packages, but I never did it myself. There is no drop-down menu at login either.

I don’t really know what nouveau is … am I going to mess anything up by uninstalling it?

If you run everything off your nvidia then having both the open source AND the proprietary installed at the same time is not a good idea. And you have a very new GPU so you SHOULD use the nvidia drivers.
Again, I don’t know about kubuntu, so to be 100% sure, you should check with them, but I see no reason it should create any problems uninstalling nouveau.

As for wayland, check if there is a package called plasma-workspace-wayland and install that.

Wait!! I just realized:

You are not on plasma 6. Disregard above about wayland, that is if you are on plasma 6.
Might still work on plasma 5, but I have no idea.
Sorry about that.

But the driver issue is still something you should look into, that could be the reason for instability.