How do I compile only one repo using kde-builder?

I downloaded and compiled plasma-workspace and all of its dependencies via kde-builder. However, when running the command a second time, it tries to compile all of the dependencies again. I already compiled the dependencies, so there’s no need to compile them again.

How do I tell kde-builder to only compile plasma-workspace?

Use --no-include-dependencies or the shortform -D

Thanks, but I got a new issue.

When using a different Git branch, my kde-builder will switch the branch back to master. How do I make kde-builder not switch branches?

--no-src option

1 Like

Thank you, both.