How to disable org.kde.powerdevil.discretegpuhelper.hasdualgpu at login?

When logging into KDE remotely, it always shows “Authenticate to check for the existence of a discrete GPU” (ID is org.kde.powerdevil.discretegpuhelper.hasdualgpu). The computer doesn’t even have a GPU, so I don’t need this check at all. I want to disable this check. Autostart is already empty. How can I disable this check?

This is a KAuth dialog, it shouldn’t appear if your system was configured correctly. I don’t think you can disable the check (would have to make sure in the code to confirm) but you can look at why your distro configuration requires authentication for this check. On a correctly configured system, it should be always accepted without user input.