How to load Wayland KDE session using my 2nd amd gpu?

Hey, so I am trying for hours on end to run steam off my 2nd gpu. Now I want to go so far to just load my entire kvm envoriment off my 2nd gpu. (amd runs more stable), I want to use my 3090 only for ai.
Here are my logs and my distro. https://oshi.at/FcDF
I am on fedora kionite silverblue.

Without knowing more information, it’s not possible to be sure, but I suspect you may be running into a known bug: 480797 – "PrefersNonDefaultGPU" setting can nonsensically end up preferring the less powerful integrated GPU in cases where the more powerful GPU is the default one