Importing .csv files when debit/credit/amount are in the same column

Using Kmymoney on Linux Mint , v5.1.2
I had to do a reinstall of Kmymoney, so did a .csv export of my two banking accounts.

Prior to the reinstall, I was able to update those accounts by importing .csv files from my bank. Those files contain a single column with the transaction amounts, with a minus (-) sign noting debits, no sign noting credits.

My previous profile(?) let me select that column for all 3 functions, amount, debit, and credit, with the debit set to a minus sign, and the credit set to blank, or no sign.

But now after the reinstall, and attempting to setup a profile for the import, I get an error msg telling me that that column is already selected as “Amount” and I cannot set it as credit or debit. But it was working that way just fine before the reinstall.

I can edit the .csv files before import and move the debits to a new column, but that is extra work I would rather not do every time I import a .csv file.

I looked for a setting that might allow that, but if it is there I cannot find it.

How can I get that capability back?



Were you on 5.1.2 before the reinstall, so you just reinstalled the same version?

Have you created the csv import profile from scratch or are you trying to use an existing profile (maybe not the same one you were using before your reinstall?) You can either check all the setting of the import profile, or just create a new one, as you should definitely be able to do what you want.

Thanks for the reply. And yes I am creating a profile from scratch. Still, after I declare that column 3 is the “Amount” column, It will not let me also select column 3 as the debit/credit column. This is a completely new install.

You can declare either an amount column OR a debit and a credit column, it doesn’t make sense to do both. See if that works.

Well, it makes sense to me if my .csv file has a single column that contains the “Amount” and a minus sign if it is a debit, and no sign if it is a credit. So in the profile wizard, I have no choice but to point to that “Amount” column to determine if an entry is a debit or credit. What am I missing here?

I’m really not sure. When you create a csv import profile, if you have
a single amount column in you csv import file, you just assign an amount
column, and debit or credit is determined by the presence or absense of
a minus sign. You do not assign a credit or debit column. On the other
hand, if your csv file has debits in one column and credits in another,
then you assign a debit and a credit column, but do not assign an amount