Is there any way to calibrate your screen in KDE Neon?

My monitors are mostly fine, but my graphic tablet’s screen has atrocious contrast/gamma issues. I realize this is not Neon’s fault, it’s my tablet’s manufacturer. But in Windows I’m able to fix it via the GPU drivers, so I’m assuming there must be a way to do that here too.

I noticed there is a gamma slider if I switch to x11, but it affects ALL of my screens, which means that if I fix my tablet, it ruins the monitors.

Is there anything I can do about it? I only just switched to Linux a couple weeks ago so there’s a possibility I’m missing something…

I’m not sure how one sets up a graphics table display, but if you do this using the System Settings → Display Configuration KCM, then there’s an ICC profile setting that is independent for each display - load your tablet’s ICC profile there and you should be good to go.

1 Like

Thanks for the response. Sadly I did try doing that earlier but it produced no results.

Fortunately, after much hair pulling, I figured out a workaround for my problem: on Windows, the tablet’s drivers do have an option to configure the display’s colors, and the device seems to retain the changes even after booting back into linux/unplugging the tablet and plugging it back in, etc.

It’s not quite as good as using the GPU to adjust the display but I suppose it will do until better support is added.

Just to see if it is possible to help you more with this situation - do I understand correctly that you did configured your table in Display Configuration, and you did set an ICC profile from an ICC file for your tablet, and it did not solve the problem of incorrect brightness?

Can you please let us know what graphics tablet are you using?

Can you please see if you can control the brightness of the tablet using the gddccontrol application?

No, I just couldn’t find an ICC profile for the tablet, so I couldn’t do anything with it.
The tablet in question is a XP Pen 12 Pro. The problem I have with it isn’t with brightness, (the tablet has physical buttons to adjust that) but contrast.

gddccontrol works, though it defaults to a generic profile. That said, it still seems to offer the same controls as the tablet’s own official drivers do on windows. That’s good, but it doesn’t really solve my problem. Lowering the contrast to a minimum makes it so that the tablet no longer burns my eyes off, but it still has trouble displaying colors… for example, on the tablet’s display I cannot distinguish between these two colors :arrow_heading_down:, whereas on my monitors it is possible to.


Making adjustments to color balancing makes no difference whatsoever, by the way.
On Windows, the way I go about it is by using AMD’s software to enable custom colors on the display and then lower the contrast from there. Once I do that, I can see colors normally like on my other screens. That’s what I’m looking to do here on Linux.

Well, low contrast will make it difficult to distinguish hues, that’s kind of the point of it, but higher contrast is too bright and the brightness control doesn’t help?

I found an article that gives a process to create an ICC profile and customize it to control for gamma - it is quite complex but maybe it will be of use to you:

Sorry, I realize it’s a bit complicated to understand what’s going on without you being able to see the tablet in person. Essentially, the contrast setting on it is useless, because it only works on a scale from overly saturated to deep fried. On 0% it is tolerable, anything above that is borderline unusable. Maybe this picture I made can help you understand? on the top row, you can see what the tablet looks like if I just use the contrast slider on gddccontrol (the results are identical if I use the official driver’s own color adjustment tool on Windows), and on the bottom row you can see what it looks like if I enable AMD’s custom color configuration for the display and reduce the contrast from 100 to 80 on it.

I will give your link a shot when I have the time as it seems rather involved, I will report back when I do.

1 Like

Well, it sort of worked, sort of didn’t. Good news is I was able to adjust the gamma settings and now I can distinguish between lighter colors. Bad news is, every value on the other end of the spectrum has now been mushed together into an unrecognizable mess. Trying to solve that by adjusting the contrast, brightness or color balance & temperature has once again proven futile.

I feel like I’ve lost enough time and brain cells trying to get this to work so I think I’ll call it a day and live with it or stick to using this tablet only on Windows until a better solution becomes available. It’s kind of a bummer because my intention was to stop using Microsoft’s garbage OS as much as possible, as soon as possible, and drawing is the one main thing I do on my computer. I can’t believe that a singular missing setting is preventing me from doing it. (why on earth does AMD not offer the same features here on Linux?? GAH) :slightly_frowning_face:

But anyways, thanks for the help, I really appreciate it.

AMD used to offer their control center on Linux some time ago (when they had the fglrx proprietary driver) and it wasn’t a great experience. These days there’s an open source driver and all the driver programing details are open and AMD expects the community to pick up the slack - which they did and there are a few good control panels available, but they are all about power management, thermals and overclocking. Sorry :person_shrugging: .

1 Like

Oh yeah, I’m not criticizing the community, they’re doing amazing stuff. My AMD cards have worked flawlessly for everything else without me having to touch anything.
In general, my whole experience has been like that. Well, minus for pipewire giving me a massive headache, but I managed to figure that one out.
Honestly, like I said, this problem I’m having has less to do with software or drivers and more with XP-Pen for selling a device calibrated by a lobotomized blind monkey, and me for buying the darned thing. I may just get rid of it and upgrade to something better or go back to screenless, who knows. What I do know is that I don’t plan on giving up on Linux over a small thing like this.

Anyhow, thanks again, and have a good day!!