Kate slow print dialog and stuck on a4 paper

new install of kubuntu 22.04.2 with kate v21.12.3, kde v5.92.0 and qt v5.15.3.

when trying to print from kate (or kwrite) it takes a minute for the print dialog box to appear. when it does it always defaults to A4 paper. /etc/papersize is set to letter.

i seem to remember this issue back in kubuntu 18.something and it was a qt library that needed to be updated. can someone point me to the fix?


Unfortunately, I can’t tell you why it takes so long to search for printers on your system. Usually CUPS is responsible for system-wide printing in the background. Maybe a printout from a GTK program like GIMP or Inkscape will help to isolate the problem.

Regarding the paper format, you should probably first check the settings for all connected printers in “System settings”. Because the interface for printing from KDE/Plasma programs has been unified. In the usual print dialog this can be set differently if necessary.

LANG=C, Systemsettings5, Printers. Default Options (Montage, indexed colors)

this is certainly becoming more interesting and confusing. the printer default is set to “letter 8.5 x 11”. if i print a test page under maintenance, it prints immediately and on 8.5x11 (same happens inside cups maintenance.)

i don’t have a default.svg, so inkscape defaults to a4. new document, change properties to letter, draw an x and print, it prints immediately on 8.5x11.

konsole screen print, kwrite and okular print have 1m10s dialog delay and default a4.
lowriter 40s delay and default letter.
abiword and gvim are immediate and letter.

so i’m not sure what to look at.