KDE 6, Discover wont launch. Global Shortcuts fail. Dbus related?

I’ve been chasing down some odd issues and can’t seem to resolve them. They both seem to point to an issue with dbus, but no idea why.

First, discover just will not open. I’ve tried reinstalling it, clearing cache.

Here’s some relevant logs

Mar 03 00:58:28 whimsicott plasma-discover[3151]: libs QList("/usr/lib/x86_64-linux-gnu/qt6/plugins", "/usr/bin")
Mar 03 00:58:28 whimsicott dbus-daemon[738]: [system] Activating via systemd: service name='org.freedesktop.fwupd' unit='fwupd.service' requested by ':1.147' (uid=1000 pid=3151 comm="/usr/bin/plasma-discover " label="unconfined")
Mar 03 00:58:30 whimsicott plasma-discover[3151]: org.kde.plasma.libdiscover: OdrsReviewsBackend: Fetch ratings: true
Mar 03 00:58:30 whimsicott plasma-discover[3151]: adding empty sources model QStandardItemModel(0x562f0b70a3e0)

Mar 03 01:03:58 whimsicott plasma-discover[3297]: kf.dbusaddons: Failed to register name 'org.kde.discover' with DBUS - does this process have per
mission to use the name, and do no other processes own it already?
Mar 03 01:05:51 whimsicott plasma-discover[3461]: kf.dbusaddons: Failed to register name 'org.kde.discover' with DBUS - does this process have per
mission to use the name, and do no other processes own it already?
Mar 03 01:09:28 whimsicott plasma-discover[5040]: kf.dbusaddons: Failed to register name 'org.kde.discover' with DBUS - does this process have per
mission to use the name, and do no other processes own it already?

Then, there’s global shortcuts. I can add program shortcuts via settings. But if I try to add a shortcut to a script or command, I get

error when communicating with the global shortcuts service

Both these seem to suggest an issue with dbus.

When I tried to restart dbus initially, I got this error

Failed to connect to bus: $DBUS_SESSION_BUS_ADDRESS and $XDG_RUNTIME_DIR not defined (consider using --machine=<user>@.host --user to connect to bus of other user)    

Then, I messed about to fix it, now I can restart dbus, but first time I did, I got a crash. Subsequent restarts just crash the desktop with no error, and must reboot to bring it back.

Ill be honest, I don’t know what’s wrong at this point.

Application: plasmashell (plasmashell), signal: Segmentation fault

[KCrash Handler]
#4  0x00007fcb30d82640 in typeinfo name for QAbstractEventDispatcher () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#5  0x00007fcb30ee77c3 in QAbstractProxyModel::roleNames() const () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#6  0x00007fcb2fad6a9c in QQmlDelegateModel::_q_modelAboutToBeReset() () at /lib/x86_64-linux-gnu/libQt6QmlModels.so.6
#7  0x00007fcb3102b7ce in  () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#8  0x00007fcb30ed3361 in QAbstractItemModel::modelAboutToBeReset(QAbstractItemModel::QPrivateSignal) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#9  0x00007fcb30efe52b in QSortFilterProxyModel::setSourceModel(QAbstractItemModel*) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#10 0x00007fcae8c5d01a in  () at /usr/lib/x86_64-linux-gnu/qt6/qml/org/kde/kitemmodels/libitemmodelsplugin.so
#11 0x00007fcb30f2a9cf in  () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#12 0x00007fcb30fd6e2d in QPropertyBindingPrivate::evaluateRecursive(QVarLengthArray<QBindingObserverPtr, 256ll>&, QBindingStatus*) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#13 0x00007fcb31e56e35 in QQmlPropertyBindingJS::expressionChanged() () at /lib/x86_64-linux-gnu/libQt6Qml.so.6
#14 0x00007fcb31e35438 in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () at /lib/x86_64-linux-gnu/libQt6Qml.so.6
#15 0x00007fcb3102b5a5 in  () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#16 0x00007fcb31e46da9 in QQmlOpenMetaObject::checkedSetValue(int, QVariant const&, bool) () at /lib/x86_64-linux-gnu/libQt6Qml.so.6
#17 0x00007fcb31ddbbb6 in QQmlPropertyMap::clear(QString const&) () at /lib/x86_64-linux-gnu/libQt6Qml.so.6
#18 0x00007fcb3102b7ce in  () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#19 0x00007fcb30fd0a83 in QObject::destroyed(QObject*) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#20 0x00007fcb30fcdffc in QObject::~QObject() () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#21 0x00007fcac6e3cc5a in  () at /usr/lib/x86_64-linux-gnu/qt6/plugins/plasma5support/dataengine/plasma_engine_clipboard.so
#22 0x00007fcb30fca0aa in QObjectPrivate::deleteChildren() () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#23 0x00007fcb30fcdfb8 in QObject::~QObject() () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#24 0x00007fcb280d782d in Plasma5Support::DataContainer::~DataContainer() () at /lib/x86_64-linux-gnu/libPlasma5Support.so.6
#25 0x00007fcb30fca0aa in QObjectPrivate::deleteChildren() () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#26 0x00007fcb30fcdfb8 in QObject::~QObject() () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#27 0x00007fcac6e10cb7 in  () at /usr/lib/x86_64-linux-gnu/qt6/plugins/plasma5support/dataengine/plasma_engine_clipboard.so
#28 0x00007fcb280e377f in  () at /lib/x86_64-linux-gnu/libPlasma5Support.so.6
#29 0x00007fcb280e38dd in  () at /lib/x86_64-linux-gnu/libPlasma5Support.so.6
#30 0x00007fcb30445495 in __run_exit_handlers (status=1, listp=0x7fcb3061a838 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true, run_dtors=run_dtors@entry=true) at ./stdlib/exit.c:113
#31 0x00007fcb30445610 in __GI_exit (status=<optimized out>) at ./stdlib/exit.c:143
#32 0x00007fcb2bfca7de in  () at /lib/x86_64-linux-gnu/libICE.so.6
#33 0x00007fcb2bfd1fbc in _IceRead () at /lib/x86_64-linux-gnu/libICE.so.6
#34 0x00007fcb2bfd5903 in IceProcessMessages () at /lib/x86_64-linux-gnu/libICE.so.6
#35 0x00007fcb3102baab in  () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#36 0x00007fcb30fddf93 in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#37 0x00007fcb30fde836 in QSocketNotifier::event(QEvent*) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#38 0x00007fcb32ff40eb in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt6Widgets.so.6
#39 0x00007fcb31063e18 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#40 0x00007fcb30e67e34 in  () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#41 0x00007fcb2f7e4d3b in g_main_context_dispatch () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fcb2f83a258 in  () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fcb2f7e23e3 in g_main_context_iteration () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007fcb30e5e1f0 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#45 0x00007fcb3106604b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#46 0x00007fcb31067c7c in QCoreApplication::exec() () at /lib/x86_64-linux-gnu/libQt6Core.so.6
#47 0x0000564fff075ad4 in  ()
#48 0x00007fcb30429d90 in __libc_start_call_main (main=main@entry=0x564fff074a90, argc=argc@entry=2, argv=argv@entry=0x7ffea9e34958) at ../sysdeps/nptl/libc_start_call_main.h:58
#49 0x00007fcb30429e40 in __libc_start_main_impl (main=0x564fff074a90, argc=2, argv=0x7ffea9e34958, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffea9e34948) at ../csu/libc-start.c:392
#50 0x0000564fff075d65 in  ()
[Inferior 1 (process 7216) detached]
1 Like

Unfortunately it sounds like the system is pretty messed up at this point, and without deep knowledge of how it works, random messing around is likely to make the problem even worse. I would recommend re-installing the system, resisting the temptation to change things you don’t understand when you have problems, and instead ask for help.

1 Like

Yep I kinda figured I messed something up.

I purged plasma related configs and installed Fedora’s plasma spin. Which was perfect anyways because I wanted to downgrade back to 5.27.

Probably a bad chown.

For what it’s worth, all of my script global shortcuts have been broken by KDE6 and I haven’t done any tampering of system internals. With KDE5 and previous, I had several Meta + {LETTER} commands that ran scripts. None of them work now, but the default ones like Meta + W for window switching work fine.

I see that KHotkeys was removed and assume this is some sort of regression?

EDIT: strangely, I just tried closing the systemsettings app and then opening it via the command line systemsettings to see if I could get any logs. Oddly enough, just reopening the settings app and again re-adding my hotkeys seemed to work. No reboot or anything.

Khotkeys being removed is a dealbreaker for me for 6. Unless some alternative exists, then I will need to insist it be added back lest I’m not sure if Ill want to upgrade anytime soon.

Rather, the xy problem here is

I use Rofi for my runner. Calling the runner is done via a command, but can also obviously be done via a script that calls that command.

But the way KDE messes with Meta makes it tricky, so I have to add the script to global shortcuts. Basically, go to global shortcuts, add the script as the action, and set an “allowed” keybind as the trigger, such as meta+something or really any keybind that isn’t just Meta by itself since KDE’s shortcuts don’t allow that.

Then, get the UUID of that created global shortcut (can be shown in kglobalshortcutsrc), and bind meta to it via qdbus, which is added under khotkeys.

`kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.kglobalaccel,/component/khotkeys,org.kde.kglobalaccel.Component,invokeShortcut,{YOUR UUID HERE}`

The fact global shortcuts was missing in 6 left me unable to figure out how to accomplish the same thing. Ill be on 5.27 til 6 is mature.

I’m actually running into the same issue here. All my shortcuts are erased on system reboot; there also appear to be a slew of old WINE applications getting pulled in in the shortcut menu. Shortcuts work fine if I re-add them at the start of the session, but this is still a big pain.

I do not use shortcuts but I have also the problem that discover will not launch.
Clicking on the icon shows the bouncing icon for a bit then it stops.
I can see this in pstree:

        |         |-plasmashell-+-plasma-discover---13*[{plasma-discover}]
        |         |             |-plasma-discover---11*[{plasma-discover}]
        |         |             |-systemsettings---16*[{systemsettings}]
        |         |             `-53*[{plasmashell}]

I’m having the same issue with Discover. When opening it via the console, it gives an error related to DBUS:

plasma-discover
kf.dbusaddons: Failed to register name 'org.kde.discover' with DBUS - does this process have permission to use the name, and do no other processes own it already?

However, reinstalling DBUS or plasma-discover doesn’t help, and clearing the cache doesn’t help either.

In general, after the update, my KDE Plasma desktop environment completely broke. I installed Gnome, and then reinstalled KDE Plasma through it. It works fine overall, except for plasma-discover."

1 Like

It is tracked here: 481993 – Discover fails to launch after upgrade to Neon 6.0