KDE fractional scaling on only one monitor

Is it possible to limit the fractional scaling to only one monitor? I have two monitors. One is 1080p the other is 1440p is it possible to usefractional scalling on the 1440p monitor only? If so how do I do it.

Yes, but only in the Wayland session. In the X11 session, scaling is global; on Wayland, scaling is per-screen, and you’ll be able to set the scale for each screen exactly how you like on the Display and Monitor page in System Settings.


Strange, isn’t 't Debian Bookworm supposed to use KDE with wayland by default?? Because I just tried that and it definitely did not work.

To check if you are running Wayland you can look in Systemsettings -> About this System and then check what Graphics Platform says.

If you are not running Wayland you can select Wayland in SDDM after logging out or rebooting.

Thanks for that tip. Apperently the debian 12 live session still runns with X11 by default.

I think “default” is only for new installations (don’t know how the debian actually handles it). If you can’t select Wayland from SDDM you might have to install a few more packages.

Just in cases someone comes across this thread and still desires per screen scaling under X11:

I use multiple monitors scaled differently in X11 by taking scaling control away from KDE and setting the scaling manually with xrandr.

Under System Settings → Startup and Shutdown → Background Services I disable:

  1. KScreen 2 and
  2. GNOME/GTK Settings Synchronisation Service.

Then I use xrandr to set the scales I want:

xrandr --output DP-4 --auto --output DP-0 --auto --scale 1.75x1.75 --right-of DP-4 --mode 1920x1200

I set this at login by including the above in /etc/X11/xinit/xinitrc.d/50-xrandr.sh.

I use the above to run a 4K screen along with a FHD screen by scaling the FHD.

Of course this is not a officially supported KDE configuration, but it’s worked fine for several years. Should anyone want more info, the arch wiki has quite a good write-up about multihead:


Hello everyone. Let me add my experience because it took me an hour or two to make things work.

  1. I disabled KScreen2 and GNOME/GTK Settings Synchronisation Service as digitaltrails suggests, though I really don’t know if it was needed
  2. I have a 1080p with DP sitting left to a 4K with HDMI. The xrandr options that work for me are:
    xrandr --output HDMI-A-0 --pos 2880x0 --primary --output DisplayPort-1 --scale 1.5x1.5 --mode 1920x1080 --pos 0x269
    Basically, this makes the 1080p come to the center vertically next to the 4k and it also handles scaling so that there is no scaling on the 1080p. Also, just to note that before this dual monitor setup I had the 4k only, configured by KDE Settings and with scaling 150% (I don’t know if it matters to these settings)
  3. VERY IMPORTANT (and not that easy to find): You have to restart plasma shell. This is done with:
    kquitapp5 plasmashell && kstart5 plasmashell
    If you don’t do that there will be some weird black gaps in the 1080p screen.
  4. Above changes are reset on reboot. How to make them permanent?
    Create file ~/.xprofile and put the xrandr command in it.
  5. Reboot and now everything works as intented