KDE Neon Plasma fails to start after login

Hi there,

after completing an update through discover, my screen stays black AFTER the login screen.
During the first login after the update, I got a popup saying Plasma couldn’t start due to low disk space.
I have since made an additional 60GB available with no success (except for the popup no longer appearing). My screen is just as black as before.

I have tried both wayland and X11 and have attempted to restart the plasma.plasmashell service to no avail.
I have also tried updating all packages through apt and fixing broken packages via recovery.

At this point I’m pretty lost. So any pointers would be appreciated.

Cheers

1 Like

I had the same problem after the Plasma 6 update. It turned out that the plasma-desktop itself had not installed because of a dependency issue.

I eventually traced this back and resolved it just by installing…
apt install libdecor-0-0

This removed a bunch of wine-related i386 libraries in the process but I can live without i386 wine for now just to get me desktop back.

1 Like

Turns out that was my issue as well. Though o had to go through pkcon and select the correct version for whatever reason.