KDE Plasma's desktop randomly stopped working

I’m on Garuda Linux. Yesterday all of the sudden all Plasma panels and the desktop disappeared (the wallpaper is all black and right clicking on it doesn’t do anything). I wasn’t tinkering with anything I had Firefox, 2 KCalcs, Kate, Steam and Discord opened. The KRunner or CTRL+ALT+T shortcut to launch terminal both still work. Usually rebooting was fixing this issue but this time it persists even after rebooting. I’ve created new user and on the new user everything works fine. I’ve tried resetting the configuration via Garuda Assistant and run below commands, but all I got were errors.

startplasma-x11 gives this error:

$DISPLAY is not set or cannot connect to the X server.

sudo startplasma-x11 returned:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
$DISPLAY is not set or cannot connect to the X server.

startplasma-wayland gives this error:

Error: could not determine $DISPLAY.
Error: Can not contact kdeinit5!
org.kde.startup: "kdeinit5_shutdown" () exited with code 255
startplasma-wayland: Shutting down...
startplasmacompositor: Shutting down...
startplasmacompositor: Done.

sudo startplasma-wayland returned:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
startplasmacompositor: Could not start D-Bus. Can you call qdbus?

And “qdbus org.kde.KWin /KWin reconfigure” returned:

Service 'org.kde.KWin' does not exist.

I’ve also tried running the oldest snapshot I could but it didn’t solve the issue. Changing themes in Setting also don’t fix the issue.

I’ve removed (or rather renamed, but the end effect is the same) the file


And the desktop started working again. All my customisations are gone, but it works again at least. I could paste the broken config file here, but I doubt it would be of use to anyone.

Sounds exactly like

You should check the contents of the file. I think there is a good chance that your config file is salvageable.

1 Like

OMG, you are right! The source of the issue was the plugin “Wallpaper Engine for Kde” especially the line:


In the file


When I tried to play that video with mpv, the mpv crashed. Once I changed it to point to other video everything has been fixed. That’s a pretty weird issue. I guess that’s what I get for having over 500 Wallpaper Engine wallpapers…

I believe this is a known bug: 469445 – Ever-growing ScreenMapping entry in config file makes plasmashell slow down and eventually crash