KDE will not accept keyboard input (on unlock screen)

I am also adding logs from journalctl, that seem relevant to me. I cannot say, however, if these entries were produced while I was trying to unlock the computer, or when I gave up and long-pressed the power off button with the screen locker still open. For reference, I am using Fedora 39, KDE Plasma 5.27.10, Kernel 6.6.13.

Jan 25 20:01:41 xps sddm-greeter[7506]: QObject: Cannot create children for a parent that is in a different thread.
                                        (Parent is QGuiApplication(0x7ffdcf6efef0), parent's thread is QThread(0x562a6bcc3270), current thread is QThread(0x562a6bd7dc70)
Jan 25 20:01:41 xps sddm-greeter[7506]: QObject::installEventFilter(): Cannot filter events for objects in a different thread.
Jan 25 20:01:42 xps sddm-greeter[7506]: file:///usr/share/sddm/themes/01-breeze-fedora/KeyboardButton.qml:19: TypeError: Cannot read property 'longName' of undefined
Jan 25 20:01:42 xps sddm-greeter[7506]: Wayland does not support QWindow::requestActivate()

There are multiple lines of the “longName” type, and my working hypothesis is that this is the error that prevented the virtual keyboard from showing up.

One more update. Downgrading the Kernel from 6.6.13 to 6.6.9 has resolved the issue for me. I would have guessed this must be a Wayland or KDE error but, for some reason, downgrading the Kernel has fixed it. I hope this helps anyone else who might have this problem.


Good job on the troubleshooting @alberto

Note that one instance of “keyboard events don’t work on the screen locker” was fixed via bug 479659 – Cannot unlock the screen if mouse pointer is moved immediately after locking. This might not be the particular issue from this thread, but if not then perhaps there’s still some relationship to the same input filter that was described in the fix.

Hi, just to update everybody I did manage to fix the issue. For some background I would have a full system crash between sometime after 2 A.M. to 7 A.M. It would crash every twelve minutes after reboot during this period. This would happen on every KDE reinstall and would persist as I switched between Arch and Fedora 39.
I traced the issue back to Kactivitymanagerd. Simply deleting the ~/.local/share/kactivitymanagerd/ directory would fix the issue without any other issues. I have used this fix multiple times over the last few months since I last visited the post and recently got notified on new activity so decided to share the fix for those having a similar issue.


# Define backup directory
backup_dir="$HOME/kactivitymanager_backup_$(date +%Y%m%d_%H%M%S)"

# Create backup
echo "Creating backup of the kactivitymanager directory..."
cp -r ~/.local/share/kactivitymanagerd/ "$backup_dir"

# Check if backup succeeded
if [ -d "$backup_dir" ]; then
    echo "Backup created successfully at $backup_dir"
    echo "Deleting the original kactivitymanager directory..."

    # Delete the original directory
    rm -rf ~/.local/share/kactivitymanagerd/

    echo "Directory deleted. KDE Activity Manager has been reset."
    echo "Backup failed or Original directory not deleted."

you can make a script to delete the problem directory with the above bash code.
Hope this helps someone :slight_smile:

Also just to add, I so far have not been able to figure out what kactivitymanagerd even does and simply disabling or masking it does not seem to help. Whatever it’s purpose simply nuking it, does not any performance or usage impact for me and everything continues to work as intended.
Kernel updates or downgrades, LTS kernels, zen and all else were also of no avail. This was specifically a KDE issue from what I could see.
This issue also only started for me when I upgraded from Fedora 38 to 39 (which is what I was trying to daily drive for a few months) and persisted when I moved back to Arch Linux. So it could be said that some update to kactivitymanagerd down the line caused this issue. Another thing worth noting, this issue would begin even on a clean install in the middle of the night. I couldn’t find anything in any of the logs telling me specifically why kactivitymanagerd was causing issues, but I know that it just was :confused:

I know this doesn’t resolve the issue entirely but I am experiencing the same issue and installed the qt5-virtualkeyboard package to enable it on the lock screen.

Further, like you I know the keyboard works fine, caps lock, number lock still light up when pressed from the lock screen and I can ssh into the system from another device with no issue.

1 Like