KJots Dependency Error: Installation Failed

I’m running KDE neon Plasma 6 desktop. After updating from version 5 to 6, KJots cannot be installed. The installation fails with dependency errors. I’ve mentioned the logs of apt below. Kindly suggest a solution to this.

Investigating (0) libkf5pimtextedit5abi3:amd64 < none -> 21.12.3-0ubuntu1 @un puN Ib >
Broken libkf5pimtextedit5abi3:amd64 Depends on libkf5pimtextedit-data:amd64 < none | 24.02.1-0xneon+22.04+jammy+release+build42 @un uH > (= 21.12.3-0ubuntu1)
  Considering libkf5pimtextedit-data:amd64 0 as a solution to libkf5pimtextedit5abi3:amd64 0
  Re-instated kpim6-kpimtextedit:amd64
  Re-instated libkf5pimtextedit-data:amd64
Done

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

The following information may help to resolve the situation:
The following packages have unmet dependencies:
 libkf5pimtextedit5abi3 : Depends: libkf5pimtextedit-data (= 21.12.3-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

The exact command to fix this issue will be appreciated.

It’s a known issue in Neon; see 482305 – Cannot install Kjots in KDE 6, dependency issue.

Apparently the app is abandoned and Neon has a policy of not shipping abandoned software. Discussion seems to be ongoing about what if anything to replace it with.

Hi fellow developer, thanks for the information. Is there any replacement you would suggest me that runs with Qt framework and has the beautify native look of the neon theme?

Hello fellow developer, KDE just released Marknote V1.1.0. It is available in FlatHub.