KMyMoney ledger view messed up


i got a problem with one account in KMyMoney. In the ledger view i see all my bookings just in the order they were entered. Normally i should see bars like “today” “this month” “last month”. These are gone. Also, it does not show any planned transactions to be done.

Somehow i must have switched something.

I already did a settings reset, but it did not help.

There is only one account with this problem. The other ones work.

Can anyone help me on this?

What version of KMM are you using, and on what platform or distribution?

Have you looked at the Configure KMyMoney… dialog? Specifically look
at the various settings in the Ledgers tab. Also check the sorting
options. I would expect those would affect all accounts, but it’s
still worth checking before we dig any deeper.

I am using the version 5.1.3-8455c873a on Windows 10 22H2.

I have looked into the dialogue and could not achieve any better result. For example the sorting is set to the booking date. But it is ignored. It is all sorted by entry order.

Also in the account settings i could not find anything.

But i saw in the documentation that there are different views “normal” and “checking” (sorry bad translation…). But i don’t know how to switch them as it was not described anywhere.

I expect it to be the account specific sorting. Open the ledger and select the account that causes the trouble. Right click on the header of the columns and check the account specific sorting.

That helped. The sorting is back to normal :slight_smile:

I got the payments back by setting the days to foresight in the payments options.

Thank you for your help!