Merkuro and Korganizer not working

I had problem with constant crashes from Korganizer for months. Even add a task or clicking on “settings” would freeze the app for minutes. Once Kalendar/Merkuro came out It started with no issue and for few days it seems less prone to crashes (even though was crashing every now and then). I was hoping to solve the problem once and for all but soon after the same issue came back. I have crashes that makes the app useless. Cannot add anything, cannot click on anything. Tried to reinstall it several time but no luck. Unfortunately I had to uninstall both apps for good even though I really liked them. My guess is something was not quite right with akonadi.

What are the versions of these applications?

i had weird issues with kalendar as well

what is the output of

akonadictl fsck 2>&1 | grep -iE 'found|no RID'

and reinstalling, even with backports and backports-extra enabled for the latest versions didn’t solve my problem.

finally using apt uninstall, purge and autoremove to eliminate all related packages

  • merkuro
  • korganizer
  • kontact
  • kaddrbook
  • kalendar
  • akonadi-server
  • kdepim-runtime
  • kdepim-addons

then doing a manual scrub of ~/.local/share and ~/.config of all the same package folders as well as anything that contained key words like

  • merkuro
  • alendar
  • organizer
  • ontact
  • addr
  • mail
  • akonadi
  • kdepim

and deleting `~/.cache

this should eliminate any trace or remnant of your install (including all your calendar and contact data)

before you reinstall check the version you have available and see if there are backports you can enable for your distro

I forgot to mention I am on latest Kde Neon.
I did purge both kalendar/merkuro and korganizer but honestly i didn’t remove the whole kde pim, akonadi included.

I did remove the folder /local/share/korganizer and run the app again. It gave me some error and re-starting akonadi made the app run. Do you think removing akonadi and start from scratch will solve the problem?
Kaddressbook seems to functioning just fine, no freezes no crashes…

i went scorched earth and now it works… that’s all i know.

1 Like

I purged everything and manual delete folders and /.cache as well.
Reinstalled both merkuro and korganizer (with all akonadi shebang as well).
Still no go to me.

Open both merkuro and korganizer. Tried to create an event but nothing.
Tried to configure Korganizer from the settings but it doesn’t even open the pop-up window.
If I try other settings from the menu (unsuccessfully) the app completely freeze.

I guess this time i give up

sorry that didn’t work.

i’m not using korganizer or merkuro, only kalendar (and kaddressbook which still comes with it for some reason).

the whole suite is problematic and i do believe they are working on it so you might be in some kind of version limbo between the old korganizer and the new merkuro

i would open a bug report at