Missing packages for kdesrc-build

Hello, when I run kdesrc-build on Gentoo, it tries to install a couple packages that my system doesn’t find:

dev-perl/YAML-XS
dev-util/cmake

I see that dev-perl/YAML-XS is listed in data/perl-dependencies/gentoo.ini, but I’m not sure about cmake. I think the correct package for cmake is dev-build/cmake. Am I missing something, or is the script incorrect?

The former never existed. I’ve sent an MR correcting this (sdk/kdesrc-build !384)

WRT the latter, you’re correct, we renamed it to dev-build/cmake recently. I’ll send an MR for that package also, but the dependency list is a lot more involved there.