New messages don't show up as notifications

Hey, I was wonder if new message notifications are supposed to be working in ruqola? I only see new messages when clicking on the channel.

I don’t see notifications at all nor does the channel highlight that it has unread messages (unless it had unread messages during startup)

If this behaviour is supposed to work how can in troubleshoot this?

I tried this on the 2.1 branch and the master branch

Hi,
I don’t understand.
You want to see new notification from message when you launch ruqola ?
(not possible).
You see notification when new message arrived here.

What do you want as features ?
Regards

Actually, what I’m trying to say is that I don’t get any notification at all when new messages arrive neither direct messages or in channels. Even in the channel/dm list at the left the colors don’t change to indicate there is a new message nor does the feature to put unread messages on top.

What I was trying to say that only when I start ruqola I see in the list of dm/channels color changes to indicate new messages.

Weird if you don’t receive any notification.
You don’t have color indicator in channel list ?
But default we have green/red/orange indicator in channel list.

So when a guy spoke to you directly you don’t have notification or color indication in channel list ?

On channel list => right click => “configure notification” is it possible to paste screenshot ? I want to see if you have default settings etc.

No notifications whatsoever when someone talks to me, I have to manually check the channel to see new messages.

org.kde.ruqola: permissionId not loaded during setup: "create-c"
org.kde.ruqola: permissionId not loaded during setup: "create-d"
org.kde.ruqola: permissionId not loaded during setup: "create-team"
org.kde.ruqola.loadhistory:  loadAccountSettings 
org.kde.ruqola: permissionId not loaded during setup: "create-c"
org.kde.ruqola: permissionId not loaded during setup: "create-d"
org.kde.ruqola: permissionId not loaded during setup: "create-team"
org.kde.ruqola: permissionId not loaded during setup: "create-c"
org.kde.ruqola: permissionId not loaded during setup: "create-d"
org.kde.ruqola: permissionId not loaded during setup: "create-team"
org.kde.ruqola: permissionId not loaded during setup: "create-c"
org.kde.ruqola: permissionId not loaded during setup: "create-d"
org.kde.ruqola: permissionId not loaded during setup: "create-team"
org.kde.ruqola: permissionId not loaded during setup: "create-c"
org.kde.ruqola: permissionId not loaded during setup: "create-d"
org.kde.ruqola: permissionId not loaded during setup: "create-team"
 room removed  QJsonArray([{"_deletedAt":{"$date":1709583027896},"_id":"GogexqM8iWfTcnQ3z"},{"_deletedAt":{"$date":1711804403753},"_id":"kCJoSgAH6fM8igT9x"}])
parse private info not implemented . Needed ? 
org.kde.ruqola.rocketchatqtrestapi: SetStatusJob: mUserId is empty
kf5idletime_wayland: This plugin does not support polling idle time
 root  QJsonObject({"id":"6","msg":"result","result":[]})
org.kde.ruqola.rocketchatqtrestapi: SetStatusJob: mUserId is empty

I spoke about channel → notification
not ruqola-kde notification dialogbox.

Do you use qt5 or qt6 version ? plasma6 ?

Sorry for the misunderstanding.

Currently I’m running Ruqola
Version 2.1.45 alpha (which was master when I build it)
with qt6.

As mentioned before older version with qt5 behave the same.
Maybe the fault is with our rocket.chat server itself? Notifications on mobile don’t work either only on desktop (official app or in browser).

Is there anything I can do to maybe get some extra logging to figure out what’s going wrong?

I was just trying to reproduce the problem with open.rocket.chat but I diddnt managed to connect to it.

However after that attempt I tried to clear all my ruqola setting
Using:

rm -rf ~/.config/ruqola* 

Switched back to our internal rocket.chat server and to my suprise the notifcations are suddenly working

yep there is a problem for connecting to open.rocket.chat.
It seems that they use a specific websocket or too many user broke connection with ruqola. (Didn’t find a solution).

I don’t understand why rm -f fixed it but happy that it works for you.