No .exe in program folder

Great program. I lost my hard drive and had to start fresh on a new pc (actually refurbished), running windows 10 Pro. I tried, without success to install and use the most recent version. One failed completely, the other had the same problem as v. 4 that I finally decided to try. The v 5 that started when the program finished installing would have been ok but when I tried to close and reopen, the program folder only had an icon, no .exe that I could use to start the program. v4 has no icon but I finally found it when I searched in the windows search bar and directed it to open the folder. There I found the short cut I agreed to have put in the start folder. I pinned to taskbar so I can now open it. Is that normal? Before, when I installed years ago, I believe it also asked if I wanted a short cut on the desktop, which is what I always used. But, there was also an .exe file in the program folder.

Another thing I discovered when I was trying to troubleshoot and read something about python problems… I looked for mine and discovered Owner>AppData>Local>Microsoft>WindowsApps has several applications that are 0 KB.
MediaPlayer
MicrosoftEdge
python
python3
Skype
Spotify
WindowsPackageManagerServer
winget

When I saw that I asked google for python download, got it, installed but it isn’t in WindowsApps. That still reads 0kb. I can’t find where it was put. Is any of this a problem?

Thanks in advance for your time.
Connie

sir, this is a wendy’s

sry, couldn’t resist.

did you download the .exe installer from here

https://binary-factory.kde.org/job/KMyMoney_Release_win64/lastSuccessfulBuild/artifact/

did you check the sha256 value to make sure it matched?

Does Wendy’s have skyfishgoo? :rofl: I’d like tomato on my Wendy’s burger, please. :smile:

One of my failed attempts was from that page, kmymoney-5.1-1959-windows-cl-msvc2019-x86_64.exe. If I recall correctly, that is the one that had an icon but no .exe. I’m not sure what you mean by check the sha256 value.

also download the file with the same name but sha256 on the end

it’s a text file that will have a long number in it.

then run whatever you utility windows provides to calculate the sha256sum of the big file with the .exe on the end.

it will spit out a long number that should match what was in the text file.

that way you know the download is not corrupted in transit, as sometimes happens.

Well, I did the research necessary to be able to do the checksum after putting both files on my desktop. But I don’t know what text file you are talking about or where to find it. This is what cmd shows me:
C:\Users\Owner\Desktop>certutil -hashfile kmymoney-5.1-1959-windows-cl-msvc2019-x86_64.exe SHA256
SHA256 hash of kmymoney-5.1-1959-windows-cl-msvc2019-x86_64.exe:
18fac7d9db6d40c10bf2416b5aee63b3d7954921abc41a1d9aaa2a51a5c015d9
CertUtil: -hashfile command completed successfully.

Oh, I needed to click “view” next to the sha256 file download link. Then it shows me the checksum data. Yes it matches.

then you got the file properly and it should do what it’s designed to do.

you are saying when you run it, that it walks you thru the typical windows install wizard but at the end when it’s done there is no desktop icon or .exe in the target folder?

did you change any of the defaults during the wizard bit, or just let it do it’s thing?

if it’s not working as expected then i would suspect the windows install is borked somehow.

Yes, I allowed it to do it’s thing during installation, both V4 and V5 and it left no .exe in the target folder and nothing on the desktop. But, as I said, V4 does have a shortcut in the start menu so I pinned that to the taskbar for easy access. I’ve only had the pc for a couple of weeks, bought it refurbished so maybe the windows install isn’t quite right. I’ve downloaded a couple of other open source programs and Adobe reader without incident though. Thanks for your time Skyfish.

I decided to restore windows back to before the last updates because started suspecting something not right with it. I installed LibreOffice and Adobe reader just fine before that last update.

I redownloaded the set up program because it wasn’t on the desktop any longer, which seemed strange. Again, it asked what start up folder I wanted it in but nothing about desktop shortcut. I opened the containing folder of the shortcut and saw that it was within the bin folder. I went to programs and found that bin folder. Way down the list of files is the gold colored icon named kmymoney.exe. It is among all the dll files, not in a folder within the bin folder. No wonder I couldn’t find it. Could there be a difference between Windows 10 Home and Pro that is a problem? I just can’t figure this out. The work around is to pin a shortcut to the taskbar for now.