No longer able to hibernate

After upgrading to Plasma 6.1.0, and now 6.1.1, hibernation appears to have been disabled on my Dell Latitude laptop running Fedora 40. When I click ‘Hibernate’ on the shutdown screen I get returned to the desktop.

Running ‘systemctl hibernate’ as root just silently returns to the command prompt.

My settings for hibernation still appear to be correct and have not changed from when it was working with Plasma 6.0

It’s not a problem with the hardware, hibernation works fine if I reboot into Windows.

I would have this up KSystemLog - KDE Applications and see what journald reports when you try to hibernate.

Thanks. Examination of the logs showed this was an issue with SELinux and not related to KDE. I’ve added a policy to allow writing to the swap file and hibernation is now functional again.