Okular doesn't open links in my default browser

Firefox Aurora is set as my default browser, but opening links in Okular causes them to open in Brave. I do not yet know if this issue occurs in other KDE Applications. Also I wish there was a "Small KDE Problem Forum thread for small issues like this that honestly do not deserve their own topic.

1 Like

If you run

xdg-open https://kde.org

does it open the correct browser?

I agree!

1 Like

You might look in “Default Applications”. I know you can assign what type file (e.g., .pdf) will open in what application in the “File Associations” tab…there’s a chance the “Application preference order” might be the problem.

when i go to default applications my web browser is set to firefox and works as expected most of the time, but occasionally things will open in falkon (which i’ve installed) … this will happen if i click on links embedded into KDE dialogs like the crash report popup.

also running xdg-open https://kde.org will take me to firefox.

most interesting tho, is if i choose the Defaults button on that settings page, then my browser resets to Falkon and i have no idea why that would get to be the default default (default^2?) since it was installed by me and not part of my kubuntu distro.

just thought that was interesting … maybe it’s a Qt thing? like how hair dog recognize each other.

Silly proposal but I’ll try: did you try setting the default browser to something else, saving, and then setting it back to firefox?

Of course.

(It won’t let me reply with less than 20 characters, so here is some useless fluff).

1 Like

setting the default browser to something else, saving, and then setting it back to firefox

This worked for me, thanks for the suggestion!

1 Like

No, it opens in Okular as well.