Opening glaxnimate in kdenlive

I installed Linux Mint, Kdenlive 23.04.3 and the latest version of Glaxnimate.
I know that I have to point to the Bin of glaxnimate in Kdenlive in the settings of animation.
But whatever I searched f.e. var/lib/flatpak/app etc I only get so far that I have a Json animattion in the sequencies. and then nothing. I presume that I haven’t found the right Bin:
I expected an automatic switch to Glaxnimate.
Can anyone give me some help about what and how I have to fill in ?

Afaik Glaxnimate works best if you use the kdenlive appimage, MLT has to be built with -DMOD_GLAXNIMATE=ON for it to work

Thanks for the info, but I am a novice user, ‘kdenlive appimage’: does it mean that I used a wrong version.
‘MLT has to be built…’ sorry but it’s beyond my knowledge, is it not build-in in Kdenlive ?

In Kdenlive Menu > Settings > Configure Kdenlive > Environment > Default Apps, my setting is /home/my_user_name/.local/share/flatpak/exports/bin/org.mattbas.Glaxnimate.

Check whether you have a similar path for Glaxnimate on your machine

Thanks, my settings are now: /run/user/1000/doc/c84241c7/org.mattbas.Glaxnimate
But I gave in: /var/lib/flatpak/exports/bin/org.mattbas.glaxnimate
When I put in in Kdenlive: Project/animation, it shows animation-0001.json in sequences.
But it does not switch to the program Glaxanimate as I expected.
Maybe I have to do this manually: start up the program, make an animation and save it as
0001.json. then it shows in Kdenlive ?

I think that can work, but the integration is the nice thing, of course. I suggest you open a bug report in about this.