Opening Update KCM from #Discover shows blank page in `plasma-systemsettings`

Does anyone know whether there’s a package that I can install to provide this functionality? It appears that OpenSUSE doesn’t install the relevant KCM by default.

Sounds like an OpenSUSE problem. I’d recommend using your package manager to search for various keywords until you find it.

1 Like

This is a problem in Discover. It doesn’t disable the menu item when Update KCM is not installed.

1 Like

Yes, that’s part of it too.

Of course, this is because Discover didn’t anticipate that the KCM would not be installed, since it lives in Discover’s own repo. But packagers sometimes like to do weird things. I think it’s on them to fix then they cause problems for themselves and their users like this.

(and yes, I know they won’t and we’ll get the blame for it, which is what always happens)

1 Like

No, I’ll ensure that I report it to OpenSUSE, DW.


Any ideas of what keywords to use, @ngraham?

https://bugs.kde.org/show_bug.cgi?id=472780#c0

This also affect(s/ed) Manjaro and Arch, per Software update section in Manjaro KDE System-settings - #6 by bogdancovaciu - Feature Request - Manjaro Linux Forum


https://bugzilla.opensuse.org/show_bug.cgi?id=1213780#c0


The package name is discover-notifier, per 1213780 – KDE Discover doesn't come include Updates KCM as dependency..