Plasma 6: Lock screen renders black (troubleshooting help)

This disappeared after updating today.

Edit: I did change from sddm to sddm-git.

:melting_face:
was happy too early. updated yesterday and its back. there are some differences but the same this is happening

This “Plasma Style” bug seems like some sort of timing and/or invalid-cache issue. Another KDE dev in the Matrix chatroom experienced it for a while on his system, but it disappeared after a few attempts to pin it down but having to restart the system in the meantime.

“There are two hard problems in software engineering: naming things and cache invalidation!”

What kind of cache are you talking about? I can reliably reproduce on a new user so I don’t think its ~./cache. Are you talking about CPU cache?

Currently my guess is that its related to the QT version. Does anybody not have the issue with qt 6.6.2 ?

Just guessing, there are a number of caches in different places so I figured one of them might be culpable. But yeah, if it happens with a new user then that’s quite unlikely so I guess not a cache thing then.

I’m running Qt 6.6.2 on Arch and am (unfortunately for fixing) not experiencing the issue. Also Plasma 6 master as of early-to-mid March or so, haven’t rebuilt most components in a while.

Are you using released Plasma from the 6.0 release branch? I went through kscreenlocker commits and saw that this one hasn’t so far been cherry-picked to the Plasma/6.0 branch. I may give it a shot later in my dev setup with that commit reverted, but if someone is already experiencing the bug and can try applying it, maybe we get lucky and it’s related.

I can repro on Arch 6.0.2, git master, and git master with self compiled qt 6.6.3. But since you cannot repro it is likely not depended on the QT version.

Can you repro on X11 when using a new user?

Note: This is a X11 only bug.

I applied that commit to kscreenlocker 6.0.2 on Tumbleweed, but no luck. The issue is still present.

1 Like

I’m also getting this issue. Black screen, only cursor shows, typing blindly password works. Turning off the lock screen in Screen Locking bypasses the issue, but not ideal.
KDE 6.0.3
QT 6.6.3
Kernel 6.6.23-1-lts (64-bit)

Tried setting pm_async to 0 in /sys/power but no luck.

Running an Intel graphics chip.
Intel Corporation Raptor Lake-P [Iris Xe Graphics] (rev 04)

Hoping a fix gets found soon!

1 Like

I’m also getting this issue on Fedora 40 running KDE. Occurs when I lock session and unlock/login I get a black screen.

If use Krunner, to logout and then log back in back in I’m back to normal running.

KDE 6.0.3
QT 6.6.2
Kernel 6.8.2-300.fc40.x86_64

I upgraded from Fedora 39 to 40 (beta) yesterday. If you need any info to help identify let me know.

As another data point, I have 2 systems running Arch, both with KDE/Plasma desktop (KDE 6.0.3 and QT 6.6.3). Both are using X11, instead of Wayland. One of them, for historical reasons, uses GDM as the login manager. That system does not have this issue with the blank screen after locking. However, the one that uses SDDM (sddm v0.21.0, sddm-kcm 6.0.3) does have this issue.

I am in the same boat as baronmog. I get a black screen with only the mouse cursor visible upon locking.

local/sddm 0.21.0-4
local/sddm-kcm 6.0.3-1 (plasma)

Operating System: Arch Linux
KDE Plasma Version: 6.0.3
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.3
Kernel Version: 6.6.24-1-lts (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-8650U CPU @ 1.90GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Manufacturer: LENOVO
Product Name: 20KHCTO1WW
System Version: ThinkPad X1 Carbon 6th

Probably known by others but just found out by myself, if when I get the blank screen, which is happening constantly now whenever I unlock a session. I can run: “kquitapp5 plasmashell && kstart5 plasmashell” and everything comes back without having to restart.

Hi everyone. A month later, is the root cause known?

I manage several identical laptops. All arch+sddm+kde. Very early on the wayland ones (default install) had this issue. Then it went away. On wayland it only happened if you tried to wake the screen right after the fadeout lockscreen animation. (edit: the wayland issue was fixed, history better explained on this comment in the new X11 ticket 481308 – screen locker black with cursor on X11 )

Now the two laptops on X11 (because screen capture needs that don’t work well under wayland) started to show this behavior after updating the Arch install last weeks. But differently from the wayland, this shows the blank screen at anytime you wake the system, not just during the fadeout animation, which is even worse. (edit, i think my system got impacted by change to fix that one bug)

it’s version 6.1 now, is this problem fixed? I’m using wayland instead currently

The bug report is still open, so no, it still exists for some people unfortunately.

After hitting it at some point and not being able to figure out the root cause, I haven’t been able to reproduce it recently on my system. This has also happened to other KDE developers. Someone with deep KDE knowledge will still has to encounter and analyze the issue before it disappears again for them.

Still happening on 6.1.2