Plasma-systemmonitor current CPU Frequency not updating

Hello, I’m trying to recreate a custom page on systemmonitor like I had on ksysguard where I have a graph with the current core speed, I’ve added the sensors in a bar graph but the values does not reflect the current core speed
The sensor I’m adding is (I’m translating) CPU > Core 1 > Core 1 current frequency (MHz) which is the first option for each core

I’ve tried from a live usb stick, same thing, I tried running

sensors-detect 

and nothing changed
If I run

cat /proc/cpuinfo | grep 'cpu MHz'

I can see the current speed for each core.
I tried adding the sensors per core manually or using the Group submenu:
using the group the exported page reads:

[Face-108771863158160][Sensors]
highPrioritySensorIds=["cpu/cpu\\\\d+/frequency"]

Entering the sensors manually

[Face-108771863158160][Sensors]
highPrioritySensorIds=["cpu/cpu0/frequency","cpu/cpu1/frequency","cpu/cpu2/frequency","cpu/cpu3/frequency","cpu/cpu4/frequency","cpu/cpu5/frequency","cpu/cpu6/frequency","cpu/cpu7/frequency","cpu/cpu8/frequency","cpu/cpu9/frequency","cpu/cpu10/frequency","cpu/cpu11/frequency"]

Some infos about the system:
Operating System: Manjaro Linux
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.9.0-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 1600 Six-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: AMD Radeon RX 580 Series
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: AB350-Gaming 3

What am I doing wrong?
TiA for the help