Possible to remove text from desktop icons

Hello, i was searching in the settings if I could remove the text from the desktop icons. I don’t find this setting. Is it possible to do it anyway, maybe through a config file? I use kde on a tablet and would use the icons as quick launcher.

Should be possible all applications have a application.desktop file located in the /usr/share/applications/ directory. Copy one of them from there to your ~/.local/share/applications/ directory as editing the system copy to remove the name is just going to get overwritten. Not sure if there is way to hide it from the system menu so a second copy does not show there but editing the GenericName setting to something different will give the duplicate a way to be distinguished from the system provided to be used for starting. Perhaps not putting the edited .desktop in the ~/.local/share/applications/ directory , the normal place for a user to have an application that is installed in their ~ directory started from and in a newly created folder for just this purpose of storing the modified files will avoid the duplicates anyways with no Generic editing needed at all, just name removal. Then do the normal right click on the Desktop and use the Create new sub menu option to go for link to application or more likely link to file as the application seems to want use existing application you specify and could use the unedited .desktop too. Where the link to file would use the edited version of the .desktop file for the link with it having no name in it. All of this is untested so you will have to try and see how it works and if my supposition is correct.

doesn’t work. I already tried this (tried it again after your explanation). When you do it this way, you get the .desktop name as text. In my case openbuilds.desktop.

Only idea I had to try, so the quest for it continues.

No problem. I already tried widgets, but because I’m on wayland these widgets behave strange. So my solution was to create big desktop icons as launcher and it looks a lot cleaner without text.

I messed with this… I created a few direct settings module launchers and put them in .local/applications (I launch from menus) so I tried copying and moving one to the desktop.

The Desktop works hard - if you remove the filename, it will simply read the file and come up with the application name.

So here’s my Plex-Webapp launcher… duplicated to the desktop.

Name =`

2023-12-30 17:18:47

So - first, copy and paste your launcher, then F2 delete the name (it gets replaced) and finally edit with kate and enter your own Name= entry which will override the longer.desktop text.

Nice to see you found solution you can use for your situation, you may want to mark this as solved.

did you try Name=""?

or will the syntax accept the ascii code for null character (00)?

It treats the name as plain text. So if you use " " then it shows " ". Same for the ascii
solution.

1 Like

Yes, the dot was the closest I could find.

It’s a shame you can’t simply assign icons, leave the file with it’s original name, but not show the name on the desktop really - but I only keep one folder on the desktop for keeping it tidy, so it’s not a huge issue for me.

You might be able to do this in a different way: by adding a “Quick Launch” widget to the desktop and then adding the launchers you want to it. If you don’t like the background, you can turn that off while in edit mode, too; press-and-hold on it, and click on the icon in its hover toolbar that’s most inscrutable. :slight_smile:

2 Likes

nice little gadget, just drag and drop

Screenshot_20240101_044310

by default it seems to prefer horizontal placement and vertical placement via edit mode can be a bit finicky…

i was able to tuck it vertically next to the edge of my screen in 5.27 by

  • “accidentally” dragging it into my vertical task bar
  • then enter edit mode on the taskbar
  • and drag it back out to the desktop for slim vertical orientation

don’t know if there is an easier way, but playing with it for 10min, i could not get it into this slim vertical orientation until the “accident” happened.

Thanks all for the responses. I tried it first with the quickstarter widget. Probably I did something wrong, because after enabling this widget, I got regular ‘black screens’ and the widget was not stable (changed from position and size) It seems the desktop reloaded. (I’m on wayland). Now it seemed to work, I created a .desktop file of the app and pulled it in the widget. Now the widget is stable and usable.

Regarding my initial question. You can remove the text from a desktop icon by making the text color translucent. I found this workaround on the endeavour os → Is there a way to hide the text below the desktop icons in Plasma? - #3 by rrx - Plasma - EndeavourOS
Although I reommend to not change the file in /usr/share, but copy the location first to your ~/.local/usr/share