PSA: Qt6.7 causes a lot of crashes

The most frequent ones have been fixed already but will only be part of next version of KDE Frameworks 6.2 and Dolphin 24.02.3.

To avoid those crashes, try to revert to Qt 6.6.