Remove a share using a csv import file

Hi everybody,

I seek your help for the following issue with a csv import file of investment shares. The KMyMoney action/type for removing a share operates as for adding a share.

I tried different options, in particular setting the quantity as a negative figure. It does not work.

I also created a toy investment account. I created the corresponding csv export file that I use for importing its operations into another toy account:

Date;Titre;Action/type;Montant;Quantité;Cours;Intérêts;Commissions;Compte;Note;État
2024-06-02;“Stock_1”;Shrsout;;“0,50”;;;;;;

I got the same result as if I had created the following scv import file:

Date;Titre;Action/type;Montant;Quantité;Cours;Intérêts;Commissions;Compte;Note;État
2024-06-02;“Stock_1”;Shrsin;;“0,50”;;;;;;

Your help would be very much appreciated.

Thank you.

René

Our most important questions at this point in time: which version of KMyMoney are you using on which operating system?

Hi,
Thank you for your reply.

The KMyMoney version is : Version 5.1.3

The characteristics of my system is

    • Hardware : Lenovo Legion Y530-15ICH-1060
    • Memory size 16,0 Gio
    • Processor : Intel® Core™ i7-8750H × 12

The issue occurs on both OS I use in dual boot:

Opensuse

    • OS openSUSE Tumbleweed
    • OS Type : 64 bits
    • GNOME version: 46
  • *Windowing system : Wayland
    • Kernel Version: Linux 6.9.3-1-default

Fedora

  • OS : Fedora Linux 40 (Workstation Edition)
  • OS Type : 64 bits
  • GNOME Version : 46
  • Windowing System : Wayland
  • Kernel Version : Linux 6.8.11-300.fc40.x86_64

Thank you

René

I tried to reproduce the problem using KMyMoney master (the current development version) and after tweaking the CSV a bit I was able to import it. Here’s the modified CSV file to fit my data file:

Date;Titre;Action/type;Montant;Quantité;Cours;Intérêts;Commissions;Compte;Note;État
2024-06-02;A200 Stock;ShrsIn;;1.50;;;;;;
2024-06-03;A200 Stock;ShrsOut;;0.50;;;;;;

and here is the result:

I had to map “ShrsIn” to “Add shares” and “ShrsOut” to “Remove shares” as part of the process in KMyMoney. That assignment seems to be persistent because when running it a second time, I was not asked for the assignment again.

It may not work with the version you have (5.1.3) but apparently was fixed in the meantime :slight_smile:

Hi,

Thank you for your explanations.

But the issue remains the same. The only difference I see between your configuration and mine is that you are using the development version of KMyMoney. I’m using KMyMoney 5.1.3 version.

As you say that the development version works well, I will wait until the development version becomes the final operational one.

As soon as KMM is updated I’ll keep you informed.

Many thanks for your kind help.

René

Hi,

Experimentally, I downloaded the development version of KMyMoney, which works perfectly.

As you said, the issue is fixed on the next release of KMM.

Thanks so much for your advice ans help.

Regards.

René