Semi-transparent black box with curved edges on desktop file text

image
Inxi -f:

System:
  Host: PC-01 Kernel: 6.6.30-2-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.4 Distro: Manjaro Linux
Machine:
  Type: Desktop System: Dell product: XPS 8940 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0K3CM7 v: A00 serial: <superuser required> UEFI: Dell
    v: 2.10.0 date: 09/14/2022
CPU:
  Info: 8-core model: 11th Gen Intel Core i7-11700 bits: 64 type: MT MCP
    cache: L2: 4 MiB
  Speed (MHz): avg: 1433 min/max: 800/4800:4900 cores: 1: 800 2: 2303 3: 800
    4: 1379 5: 800 6: 2720 7: 800 8: 800 9: 2291 10: 2096 11: 853 12: 2988
    13: 800 14: 1911 15: 799 16: 800
Graphics:
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] driver: i915 v: kernel
  Device-2: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] driver: nvidia
    v: 550.78
  Device-3: Logitech HD Webcam C615 driver: snd-usb-audio,uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau dri: iris
    gpu: nvidia,nvidia-nvswitch resolution: 1: 2560x1440 2: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: iris,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
    renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
  API: Vulkan v: 1.3.279 drivers: nvidia,intel surfaces: xcb,xlib
Audio:
  Device-1: Intel driver: snd_hda_intel
  Device-2: NVIDIA GA106 High Definition Audio driver: snd_hda_intel
  Device-3: Logitech HD Webcam C615 driver: snd-usb-audio,uvcvideo type: USB
  API: ALSA v: k6.6.30-2-MANJARO status: kernel-api
  Server-1: PipeWire v: 1.0.5 status: active
Network:
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi
  IF: wlo1 state: up mac: 00:93:37:45:7d:ce
  Device-2: Realtek Killer E2600 GbE driver: r8169
  IF: enp4s0 state: down mac: b0:4f:13:16:ca:11
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
Drives:
  Local Storage: total: 4.44 TiB used: 1.36 TiB (30.6%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM991a NVMe 512GB
    size: 476.94 GiB
  ID-2: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB
  ID-3: /dev/sdb vendor: Samsung model: SSD 870 EVO 2TB size: 1.82 TiB
  ID-4: /dev/sdc vendor: Seagate model: OneTouch SSD size: 931.51 GiB
    type: USB
  ID-5: /dev/sdd vendor: SanDisk model: USB 3.2Gen1 size: 114.6 GiB
    type: USB
  ID-6: /dev/sde vendor: PNY model: USB 3.1 FD size: 230.96 GiB type: USB
Partition:
  ID-1: / size: 960.16 GiB used: 396.3 GiB (41.3%) fs: ext4 dev: /dev/sdb4
  ID-2: /boot/efi size: 511 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb2
Swap:
  ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) dev: /dev/sdb3
Sensors:
  System Temperatures: cpu: 58.0 C pch: 59.0 C mobo: 48.0 C gpu: nvidia
    temp: 57 C
  Fan Speeds (rpm): cpu: 1007 fan-1: 791 gpu: nvidia fan: 0%
Info:
  Memory: total: 48 GiB note: est. available: 46.63 GiB used: 3.51 GiB (7.5%)
  Processes: 357 Uptime: 15m Shell: Zsh inxi: 3.3.34

This is the fallback for missing shadows when you’re in software rendering mode. Did you deliberately enter this mode somehow?

I didn’t. This started after I rebooted (in that last post). I did notice that my rendering settings were set to software rendering.

I just changed the renderer to OpenGL in the Plasma Render settings and now everything works fine.