Sleep on my new ThinkPad only works on GNOME


I’m a KDE fan but currently sleep only works with GNOME on my ThinkPad T14 G3 Intel.


Laptop connected with lid closed external monitor via USB-C hub ( device XHCI). Initiating “sleep” will put the laptop into sleep for 2 seconds then it comes back on and shows the lock screen.

What I’ve tried already:

  • different distros / Kernels. Always the same so this is definitely related to KDE

  • various BIOS settings changes (no effect)

  • disabled KScreen 2 background service in Plasma

  • disable automatic screen locking after suspend in Plasma

What I managed to figure out:

  1. it has something to do with the USB-C hub (device XHCI), particularly the Logitech wireless mouse

  2. I think the mouse is preventing the laptop from sleeping

But how would you troubleshoot this?

Clearly this must have something to do with how KDE handles power saving but I fear its not something you can easily manipulate.

And obviously GNOME must be doing something different in that regard

Any ideas on how to still make KDE work would be appreciated.

Thank you

  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
  Device-1: 1-3:14 info: Synaptics type: <vendor specific> rev: 2.0
  Device-2: 1-4:3 info: Luxvisions Innotech Integrated RGB Camera
    type: Video rev: 2.0
  Hub-2: 1-6:4 info: VIA Labs USB2.0 Hub ports: 5 rev: 2.1
  Device-1: 1-6.1:7 info: Logitech Logitech Webcam C925e type: Video,Audio
    rev: 2.0
  Device-2: 1-6.2:8 info: Shenzhen Rapoo 2.4G Wireless Device
    type: Mouse,Keyboard rev: 2.0
  Device-3: 1-6.3:9 info: Logitech Logi Bolt Receiver
    type: Keyboard,Mouse,HID rev: 2.0
  Device-4: 1-6.5:10 info: VIA Labs PD3.0 USB-C Device type: Billboard
    rev: 2.0
  Device-5: 1-8:5 info: Alcor Micro AU9540 Smartcard Reader type: Smart Card
    rev: 2.0
  Device-6: 1-10:6 info: Intel type: Bluetooth rev: 2.0
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1
  Device-1: 2-1:2 info: Silicon Motion - Taiwan (formerly Feiya ) Flash
    Drive type: Mass Storage rev: 3.0
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
  Hub-5: 4-0:1 info: Super-speed hub ports: 3 rev: 3.1
  Hub-6: 4-3:2 info: VIA Labs USB3.0 Hub ports: 4 rev: 3.2

CPU: 10-core (2-mt/8-st) 12th Gen Intel Core i5-1235U (-MST AMCP-)
speed/min/max: 407/400/4400:3300 MHz Kernel: 6.1.0-13-amd64 x86_64 Up: 5h 49m
Mem: 6989.1/15691.7 MiB (44.5%) Storage: 525.51 GiB (8.6% used) Procs: 320
Shell: Bash inxi: 3.3.26
1 Like

did you specifically try disabling the wake on mouse in the BIOS?

or perhaps there is an acpi disconnect that needs to be addressed.

i use a kernel parameter to fool my ancient bios into thinking i’m running windows 2009 so it offers up all the firmware functions to linux.

some further reading on the kernel param

Thanks for the suggestions. Sadly I don’t think there is the option to set “wake on mouse” in the BIOS. Will have a look at the Kernel param stuff but since its related to the DE how likely is it that the Kernel plays a role?

dunno, but KDE has settings for direct and detailed control over the power management features that require certain acpi features be available to it, perhaps other DE’s like gnome use a different approach to power management that rely less on the firmware.

just spit balling.

1 Like

Ah I see what you mean. That’s definitely something to consider then. Thanks

OMG. I found a solution. When I use DP instead of HDMI, Plasma can put the laptop to sleep and wake it up with the mouse or keyboard.