Sound configuration (with Audacity)

I am running Arch, and it recently did a full upgrade of KDE. So far, no complaints (even with Wayland). But I found it confusing that even tho other applications could play sound just fine, Audacity did not. There was no way to pick “default” as the sound playback device. Drove me a bit nuts for an hour.

I stumbled across this in the KDE settings and turned both on. Audacity now works (I can pick ‘default’).

In ‘sound’ turn on “Add virtual output device for simultaneous output on all local sound cards” and turn on “Automatically switch all running streams when a new output becomes available.”

If you are running a fresh install, I would almost bet these are on by default. But I am running an upgrade to an existing KDE.