Still having an unmet dependencies issue on KDE Neon. What's the fix? (Can still update via Discover for odd reason)

When I run sudo pkcon refresh and then sudo pkcon update, I get this:

Fatal error: The following packages have unmet dependencies:
  kio-extras5: Depends: kio-extras5-data (= 4:24.02.0-0xneon+22.04+jammy+release+build3) but 4:24.02.0-0xneon+22.04+jammy+release+build4 is to be installed
  neon-ubuntu-advantage-tools: Breaks: ubuntu-advantage-tools

When I run this:

sudo pkcon install libdecor-0-0 libsdl2-2.0-0 plasma-desktop plasma-desktop-data kio-extras --allow-reinstall

I get this:

Resolving                               [=========================]         More than one package matches:
1. kio-extras-4:24.02.0-0xneon+22.04+jammy+release+build36.amd64 [auto:local]
2. kio-extras-4:24.02.0-0xneon+22.04+jammy+release+build40.amd64 [user_jammy-jammy-main]
Please choose the correct package: 

I get this after choosing number 2:

Fatal error: The following packages have unmet dependencies:
  kio-extras: Depends: libtag1v5-vanilla (>= 1.13.1) but 1.11.1+dfsg.1-3ubuntu3 is to be installed

Choosing number 3 works fine. But it doesn’t fix the issue with updating.

If I run this:

sudo pkcon install libtag1v5-vanilla --allow-reinstall

I get this:

Fatal error: The following packages have unmet dependencies:
  neon-desktop: Depends: kaccounts-providers but it is not going to be installed
                Depends: kinfocenter but it is not going to be installed
                Depends: kio-extras but it is not going to be installed
                Depends: kwin-wayland but it is not going to be installed
                Depends: kwin-x11 but it is not going to be installed
                Depends: powerdevil but it is not going to be installed
                Depends: sddm-theme-breeze
                Recommends: bluez-cups but it is not going to be installed
                Recommends: dolphin but it is not going to be installed
                Recommends: dolphin-plugins but it is not going to be installed
                Recommends: firefox but it is not going to be installed
                Recommends: fwupd-signed but it is not going to be installed
                Recommends: gwenview but it is not going to be installed
                Recommends: hplip but it is not going to be installed
                Recommends: kde-spectacle but it is not going to be installed
                Recommends: kdeconnect but it is not going to be installed
                Recommends: kdeplasma-addons but it is not going to be installed
                Recommends: kdialog but it is not going to be installed
                Recommends: kio-gdrive but it is not going to be installed
                Recommends: kio-gdrive-5 but it is not going to be installed
                Recommends: konsole but it is not going to be installed
                Recommends: kscreen but it is not going to be installed
                Recommends: kwrite but it is not going to be installed
                Recommends: neon-adwaita but it is not going to be installed
                Recommends: okular but it is not going to be installed
                Recommends: phonon4qt5-backend-vlc but it is not going to be installed
                Recommends: phonon4qt6-backend-vlc but it is not going to be installed
                Recommends: plasma-browser-integration but it is not going to be installed
                Recommends: plasma-nm but it is not going to be installed
                Recommends: plasma-systemmonitor but it is not going to be installed
                Recommends: plasma-workspace-wayland
                Recommends: printer-driver-splix but it is not going to be installed
                Recommends: snapd but it is not going to be installed
                Recommends: vlc but it is not going to be installed
  plasma-desktop: Depends: plasma-workspace (>= 4:6.0.2) but it is not going to be installed
                  Recommends: kde-style-oxygen-qt6 but it is not installable
                  Recommends: kinfocenter but it is not going to be installed
                  Recommends: kio-extras but it is not going to be installed
                  Recommends: kscreen but it is not going to be installed
                  Recommends: kwin-wayland but it is not going to be installed or
                              kwin-x11 but it is not going to be installed
                  Recommends: powerdevil but it is not going to be installed

Fix for this?

Similar problem, pkcon update results in:

Fatal error: The following packages have unmet dependencies:
neon-ubuntu-advantage-tools: Breaks: ubuntu-advantage-tools

Sudo apt full-upgrade shows no problems.
Discover shows “up to date”.

When I do sudo apt full-upgrade, I get this:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) kio-extras5:amd64 < 4:24.02.0-0xneon+22.04+jammy+release+build3 @ii umH Ib >
Broken kio-extras5:amd64 Depends on kio-extras5-data:amd64 < 4:24.02.0-0xneon+22.04+jammy+release+build3 -> 4:24.02.0-0xneon+22.04+jammy+release+build4 @ii umU > (= 4:24.02.0-0xneon+22.04+jammy+release+build3)
  Considering kio-extras5-data:amd64 1 as a solution to kio-extras5:amd64 102
  Added kio-extras5-data:amd64 to the remove list
  Fixing kio-extras5:amd64 via keep of kio-extras5-data:amd64
 Try to Re-Instate (0) kio-extras5-data:amd64
Done
Entering ResolveByKeep
Calculating upgrade... Done
The following packages have been kept back:
  kf6-kfilemetadata kio-extras kio-extras5 kio-extras5-data krename libk3b8
  libk3b8-extracodecs libtag1v5 libtag1v5-vanilla python3-update-manager
  update-manager-core
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.

Actually, this part gave me the answer:

kf6-kfilemetadata kio-extras kio-extras5 kio-extras5-data krename libk3b8
  libk3b8-extracodecs libtag1v5 libtag1v5-vanilla python3-update-manager

And all I ran was this:

sudo pkcon install kf6-kfilemetadata kio-extras kio-extras5 kio-extras5-data krename libk3b8 libk3b8-extracodecs libtag1v5 libtag1v5-vanilla python3-update-manager --allow-reinstall

Then I selected the packages from [auto:user_jammy-jammy-main] (number 2) for each of those held back packages.

Now I can run pkcon update again without that dependency issue.

This may be a similar issue for you too.

So, for me, looks like it’s resolved now after running sudo apt full-update again.
pkcon update now shows “No packages require updating to newer versions.”
I guess it was just a glitch in the recently released packages.

Yeah. But also, I think because I’ve had the same installation for 5 years, that’s probably why too.

Like, I lot of old i386 packages no longer became relevant after what I did. Not that i386 is important on a 64 bit OS. So, I was able to safely auto remove them.

Also, I discovered that neon-ubuntu-advantage-tools can be an issue when reinstalling those packages.

So the solution to that is just to run sudo pkcon remove neon-ubuntu-advantage-tools on that.

Then run:

sudo pkcon install kf6-kfilemetadata kio-extras kio-extras5 kio-extras5-data krename libk3b8 libk3b8-extracodecs libtag1v5 libtag1v5-vanilla python3-update-manager --allow-reinstall

I’ll mark this as case closed for myself.

1 Like