Stumped - cannot run kdenlive or build git version

My openSuse Leap 15.5 system upgraded to the Nvidia driver 470.239.06 for my old GeForce GT-710 video card. Now trying to start kdenlive from the command line fails with “cannot initialize GLX” error, but trying to use cmake to build the git version of kdenlive fails because it cannot find the KF6 modules. I am in a catch-22 situation, what should I do next? I am reluctant to tackle building the Plasma 6 desktop. I want the ability to use this video editor.