Symlink icons not appearing

Many of my desktop symlinks don’t have the symlink overlay on them - a few do, most don’t.

Here’s a screen shot showing two folders on the desktop, both are symlinks, but one has the overlay and the other doesn’t:

image

Here you can see the two files in ~/Desktop:

dave@MONOLITH:~/Desktop$ ll WD*
lrwxrwxrwx 1 dave dave 18 Nov 16 21:12 WD10TB -> /media/dave/WD10TB/
dave@MONOLITH:~/Desktop$ ll Li*
lrwxrwxrwx 1 dave dave 37 Dec  8 11:42 Linux_setup -> /home/dave/Desktop/WD10TB/Linux_setup/
dave@MONOLITH:~/Desktop$

The same problem happens with individual files that are symlinks (not just directories).

How can I fix this?

Additional info: FWIW, whenever I right-click on a desktop symlink and select “Properties”, Plasma crashes (I get the black screen then in restarts). I don’t know if that’s related.

Operating System: KDE neon 5.27
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.113.0
Qt Version: 5.15.11
Kernel Version: 6.2.0-37-generic (64-bit)
Graphics Platform: X11
Processors: 32 × 13th Gen Intel® Core™ i9-13900K
Memory: 62.6 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2
Manufacturer: Micro-Star International Co., Ltd.
Product Name: MS-7D30
System Version: 1.0

I confirm the bug on Plasma 5.27.10/Manjaro.

Inside Dolphin that symlink tag appears but not on desktop.

The symlink tag appear on top of linked folders only if previews are generated inside them.

1 Like

It’s a known bug; see 477689 – Draw symlink emblem for desktop icons with no thumbnail that are symlinks.