Unable to bind script to meta

Previously, I had my meta key bound to launch a script. I don’t remember the exact setup, but I essentially had a desktop file pointed to the script, had the .desktop in shortcuts under applications, and had my kwinrc configured with this
[ModifierOnlyShortcuts]
Meta=org.kde.kglobalaccel,/component/launcher_t7_desktop,invokeShortcut,_launch

At some point I screwed this up. Perhaps with fiddling with permissions or otherwise. I’ve just generally been messing about my system past couple days.

Ive tried many many solutions. Clearing the Meta=, deleting kwinrc, resetting shortcut configs, alt+f1 methods I see mentioned everywhere, etc. I’m at my wits end here as I’ve tried every solution I could read about short of installing and using other packages to mess with the meta key outside KDE’s capabilities.

I even up to 6 today just to see if by some grace it fixed it. Nope.

On 5.27, I was able to add a script to shortcuts and bind meta… But pressing meta doesn’t run it.

After updating to 6, settings won’t even let me get this far, as I now get this error:

error when communicating with the global shortcuts service