Why does kstart5 use such strange syntax for its `--!+command` parameter?

kstart5 has some rather interesting syntax for one of its parameters:

Usage: kstart5 [options]
Utility to launch applications with special window properties 
such as iconified, maximised, a certain virtual desktop, a special decoration
and so on.

-h, --help                   Displays help on commandline options.
--help-all                   Displays help including Qt specific options.
-v, --version                Displays version information.
--author                     Show author information.
--license                    Show licence information.
--desktopfile <file name>    The base file name of the desktop entry for this
--!+command                  Command to execute
--service <desktopfile>      Alternative to <command>: desktop file path to
							start. D-Bus service will be printed to stdout.
							Deprecated: use --application
--application <desktopfile>  Alternative to <command>: desktop file to start.

This caused me a lot of headscratching until somebody online suggested me to escape the ! with a \, which finally made it work.

But why on Earth does it use this strange syntax specifically for that one parameter? Why not simply call it --command? The other ones use sane syntax such as --service or --application, so why --!+command?

To make it clear, you literally have to run it like: kstart5 --\!+command whatever. Why not: kstart5 --command whatever?

kstart5 dolphin works just fine for me. You don’t need to use that parameter at all. Maybe it’s just bad documentation?

See Rework kstart command line help (!87) · Merge requests · Plasma / KDE CLI tools · GitLab

the command is a positional argument, so kstart5 <command> is enough. My best guess is that !+ was special syntax to declare positional arguments at some point

Well, I just discovered that regardless of whether the strange syntax or just kstart5 test blabla is used, kstart5 thinks that “blabla” is part of the parameters I send to kstart5, rather than the command I want it to run! How do I get around that? With terminals, it’s usually -e or -x followed by a string, but here there is no such thing?

Nice to see that at least it is known and being worked on!

Well, after finally learning about the undocumented, secret -- syntax to make the damn thing actually run the command properly, I’m very sad to report that the issue remains. The stupid programs open with the orange highlight nonsense even when started with:

exec('setsid -f kstart5 -- ' . $actual_command .  ' >/dev/null 2>&1 &');

What am I supposed to do now? I’ve asked several times and can’t very well make another question about this. All I need to know is what KDE’s autostart mechanism uses to avoid the orange highlight stuff!