Why doesnt KDE forums support dark themes?

Why doesnt KDE forums support dark themes?

It does. It’s not automatically selected, but you can enable it by going to your profile, then Preferences, then Interface: under Color Scheme, for Dark mode select one of the options (by default is set as “same as regular”) and save the changes.

2 Likes

my bad, I didnt realize i phrased it wrong,

why doesnt KDE forums automatically synchronize with system theme?

Umm…
How would the website know what your system theme is??:thinking:
Your browser can probably do that, and have an extension for it to apply a dark scheme to all websites.

opensuse forums does it just fine

Websites can do a media query to detect the preferred mode.
Discourse supports this out of the box. The admins just need to click a checkbox. No idea why this has not happened yet.

1 Like

Ahh, I see.
I now have another research rabbit hole to go down… thank you :rofl:

1 Like

Does not the plasma integration plugin in firefox make the forum adhere either?
I do not have it installed.
Would be pretty comical if the official KDE forum would not listen to the official KDE plugin. :hugs:

I also do not have this activated.

That might change things. xD

Because in my opinion, not having the plugin installed, any website I visit should not know a god da*n thing about me unless I want them to. EVEN small things like this. So I don’t see this as a bad thing.

I also have tons of tweaks to further my protection, so I’m not necessarily the best ginnypig when it comes to stuff like this. :innocent:

idk if integration plugin even does any thing, have not found a feature to use it with yet, keeping installed though, just incase…

It does; if it doesn’t it’s your browsers problem

“theme default” is what allows auto theme change, this is not in the selection menu and therefore cannot be accessed

this is what it should say,
image

this is what it actually says
image

It does work for me using Firefox

oh, i get it now, it appears I had a major skill issue :rofl: :moyai:

(it works now, thank you for bearing with me and my straightup silly mistake)

1 Like

Note that on mine it was set like this by default:

Screenshot_20240324_124419

So the default config may have to be changed so that new users get auto dark mode .

1 Like

I’ll see what I can do about this.

2 Likes

See this link for the location of the checkbox which enables dark mode guests: Dark mode for forum? - #53 by Salt505 - Forum Meta - Signal Community