Windows not adhereing to system settings

Latest Kubuntu 22.04. Fresh install. Changed window settings to “shade”. A lot of windows work properly, but a lot (Firefox, Brave-browser, thunderbird, etc. don’t adhere to this setting. They all expand to full screen when double clicking the title bar.

Is this a bug? Or, how to fix?

Every application you list is not a QT/KDE application. Therefore do not follow its programming guidelines, how to fix is easy get the developers to use QT which KDE in Kubuntu does use, not the GTK they currently use. Good luck with that happening until it does you get the GTK applications behaviour with them.

Thanks. I don’t remember having this problem in 18.04. I guess I’ll live with it.

I know this doesn’t help right now, but I run Brave and it offers a setting to choose GTK or QT and works pretty well. So, it is possible for these application programmers to make this happen. You can put in bug reports or feature requests with the app devs. The squeaking wheel gets the grease.

1 Like