Adjusting automatic filtering in csv import


I regularly import cvs files to my KMyMoney database, however, there is an autmatic matching of “payment recipients” (betalningsmottagare in Swedish) that tends to have its own ideas, at times messing things up and leading to wrong categorization of payments. I have adjusted this before, but can not now find how and where. Anyone have advice for me?


We refer to the Swedish betalningsmottagare as payee.

There are a few mechanisms that play a role here. Foremost, it is the payee matching. That will allow different presentations of the same payee. Once the payee is identified, there is the ability to setup a default category for that payee. The settings for it can be found in the payees view after selecting the payee.

In case no default category is assigned, KMyMoney searches a transaction in the past where the amount is closest to the one of the imported transaction and uses that category assignment. In case an exact match is found it is used. The search is performed going back in history (based on the post dates of the transactions). I think all accounts are taken into account for that search.

Does that make sense and help to understand what is going on?


Thanks. It helps somewhat. However, I still don’t understand the mismatching of payees. For instance, I have a payee called Friskis & Svettis. This is consistenty identified by KMyMoney as IF (which is a totally different payee). How can I adjust this automatic matching?


Hi, can you post a screen shot of the two payees that shows their entries for matching? This is what I am looking for:



There is nothing. See here:

And the other:

I’m not sure if it matters, but what is the value of the dropdown above that empty list? Have you tried using different settings of that dropdown?


Do you mean this:

What it says now, is “no matching” (although in the screenshot, another option is highlighted". Could that play a role here?

Wait, it might be what makes a difference! I might have accidentally changed it from “partially matching” to “no matching”. Now it works as I want! Thanks!