After working fine, audio is unavailable: "No output or input devices found"

Hi All, experienced with Fedora, new to KDE…

Here’s my situation:

Fedora Server 38, fresh installation, JUST SERVER - NO GNOME (!!), then an installation of KDE with a few utilities from other distributions. At this point I had rhythmbox working just fine.

The next morning I wasn’t playing any music, so I don’t know WHEN the problem occurred and therefore exactly what changed, but to finish things off, I needed to add some scanner software, didn’t know much about the available packages so I installed some for testing, including two non-scanner-related packages:

gimp skanlite sane gscan2pdf simple-scan kdenlive

Probably not related but maybe: I also had mounted some NFS disks from the local net and needed to update the system’s authorization files, so I moved in configurations for a number of other users and groups so that the file permissions information is all available on this box (I run a modest server farm). It’s possible but unlikely I botched the auth-files somehow since perhaps the programs were perhaps still running with old auth data.

OH, and if it might matter: I’ve had SERIOUS problems with “Wayland”, I can’t even log in successfully with it - the session always crashes - yet KDE’s cog-wheel type icon there during login somehow disappeared, thus taking the “Xorg” login option away, and so, not taking the time to do it better, I’m now logging in to “multi-user mode” (textually,) and then running xinit with a pointer to the KDE startup program. This works fine but it does change the ownership of some running processes from root to my user-id. AND, notably, I was running rhythmbox and playing music as I worked AFTER having done this, so I think it’s unlikely it’s related to this audio problem, but I don’t really know that

Later, when I decided to play something, I discovered that the speaker icon on the lower right has a red slash across it and when mouse-hovered over it says: “No output or input devices found”

Since then I’ve done a LOT of homework to fix it, including swapping out the whole operating system disk for one from one of the server systems, and thus proved the hardware is just fine.

Along the way I found that there was a conflicting version of pipewire, namely:

  • package pipewire-pulseaudio-0.3.80-1.fc38.x86_64 from @System conflicts with pulseaudio provided by pulseaudio-16.1-4.fc38.x86_64 from fedora
    (and a dozen similar entries were found)

So I fixed that.

Some software packages claim there’s no audio hardware, but alsactl says there are either two or three audio “cards”, depending on whether or not I’ve got a USB based plug-and-play controller plugged in. The other two are HDMI, and “Realtek ACL1220”. There are SIX HDMI-capable monitors (all connected via “displayport” connectors - more on that in a moment), and while I’ve NEVER used them, these ASUS monitors MAY have built in speakers - I don’t know. Meanwhile the Realtek is a garden-variety built-in affair that comes with the motherboard.

I’ve tried “dnf update”, installed alsa-tools, alsa-ucm-utils,
pulseaudio-utils and pulseaudio itself (which is when I found the conflict noted above), and tried using these as best I can as a Linux audio novice … and everything else I can think of…

OK, short of a fresh installation and NOT installing things I now know I won’t need, have you got any ideas or suggestions please?

change rhythmbox over to using alsa unless you need to have more than one audio source going at once.

probably pulseaudio comes in with the DE so by not installing that, you don’t get all the niceties, but alsa should still be there.

Hi skyfishgoo,

thanks for replying… Unfortunately ALL sound is off, VLC, you-tube videos, you name it, NO audio; this isn’t just a rhythmbox issue.

What I need is to have ANY audio sink available!

And I may well need multiple audio source streams going at once from time to time, however, at the moment, that’s surely secondary!

Further ideas?

(BTW, I am such a newbie to this that I don’t have a clue how I’d point any source to any particular audio system, such as alsa, as you suggest.)

did you install alsa and pulseaudio… maybe reinstall them just to make sure all the dependencies are included.

if pusleaudio is running then any audio software should be able to run any of your audio devices.

you can learn more about the commands and how to check the status on each by viewing the manual pages.

man alsa
man pulseaudio

if the man pages don’t show, then you don’t have them installed.