Akonadi / KOrganizer does not connect to Nextcloud / WebDAV (on EndeavourOS)


I am trying to connect Akonadi / KOrganizer (5.24.1 (23.08.1)) to the calendars on my Nextcloud server, using WebDAV.

When I add a WebDAV resource in KOrganizer and fill out the username, URL, and (generated) password, it all seems fine. Even the Connection test passes.

But at the very next step, when I should see the CalDAV and CardDAV resources, I do not see them, could not figure out how to get it to find them, and therefore cannot proceed.

(I apologise for the language, I changed it in KOrganizer, but the wizard did not inherit it)


I have the following installed:

local/kdepim-addons 23.08.1-1 (kde-applications kde-pim)
    Addons for KDE PIM applications
local/kdepim-runtime 23.08.1-2
    Extends the functionality of kdepim
local/libkdepim 23.08.1-1
    Libraries for KDE PIM applications
local/akonadi 23.08.1-1
    PIM layer, which provides an asynchronous API to access all kind of PIM data
local/akonadi-calendar 23.08.1-1
    Akonadi calendar integration
local/akonadi-calendar-tools 23.08.1-1 (kde-applications kde-pim)
    CLI tools to manage akonadi calendars
local/akonadi-contacts 23.08.1-1
    Libraries and daemons to implement Contact Management in Akonadi
local/akonadi-import-wizard 23.08.1-1 (kde-applications kde-pim)
    Import data from other mail clients to KMail
local/akonadi-mime 23.08.1-1
    Libraries and daemons to implement basic email handling
local/akonadi-notes 23.08.1-1
    Libraries and daemons to implement management of notes in Akonadi
local/akonadi-search 23.08.1-1
    Libraries and daemons to implement searching in Akonadi
local/akonadiconsole 23.08.1-1 (kde-applications kde-pim)
    Akonadi management and debugging console
local/libakonadi 23.08.1-1
    Libraries used by applications based on Akonadi
local/merkuro 23.08.1-1 (kde-applications kde-pim)
    A calendar application using Akonadi to sync with external services
local/zanshin 23.08.1-1 (kde-applications kde-pim)
    To-do management application based on Akonadi
local/korganizer 23.08.1-1 (kde-applications kde-pim)
    Calendar and scheduling Program
local/kaddressbook 23.08.1-1 (kde-applications kde-pim)
    KDE contact manager
local/kalarm 23.08.1-1 (kde-applications kde-pim)
    Personal alarm scheduler
local/kleopatra 23.08.1-1 (kde-applications kde-pim)
    Certificate Manager and Unified Crypto GUI
local/kmail 23.08.1-1 (kde-applications kde-pim)
    KDE mail client
local/kmail-account-wizard 23.08.1-1 (kde-applications kde-pim)
    KMail account wizard
local/mbox-importer 23.08.1-1 (kde-applications kde-pim)
    Import mbox files to KMail
local/pim-data-exporter 23.08.1-1 (kde-applications kde-pim)
    Import and export KDE PIM settings
local/pim-sieve-editor 23.08.1-1 (kde-applications kde-pim)
    Mail sieve editor

My Nextcloud server uses 2FA, so to connect it to Akonadi / Korganizer I need to generate a one-time password. That should make it any different, but I mention it just in case.

Works elsewhere

On the same machine, the official Nextcloud app works fine.

On the same machine, I can connect fine with Thunderbird (using the same generated password!).

On a different machine (running Manjaro), I can connect fine with Akonadi / KOrganizer (using a generated password).

This is cross-posted also on EndeavourOS forums. I apologise for that, but I cannot figure out where this issue originates, and not having calendars is quite annoying, to say the least.

You need to add the CalDav and CardDav manually, using the “Dodaj” (Add) button. In the NextCloud interface, you can find links to the relevant DAV URLs but it’s usually https://<your nextcloud URL>/remote.php/dav/.

1 Like

Thanks, this worked. :smiley:

Odd that it did not automatically find it though … it used to :face_with_raised_eyebrow:

Yeah there’s definitely something funky going on. It really should fill it in automatically :smiley:

There’s a bug, and I have a pending fix for it


Fix reading DAV provider properties (!133) · Merge requests · PIM / KDE PIM Runtime · GitLab fixes the issue


Yay, thank you! Looking forward to trying it out proper now :slight_smile: