Alpha Transparent theme has no blur. Theme issue? Or Plasma 6 issue?

I am wanting to use an alternative to Kvantum. And they best theme I found that seems to suit blur transparent windows is this theme: Alpha - KDE Store

But this theme doesn’t seem to blur at all. And is glitching. I notice this with any color theme that has any kind of blurred transparency. And it is see though.

Is there a fix for this?

The default Blur effect only blurs windows that “ask” for it e.g. Konsole. If you want to force blur on other windows you can use kwin-effects-forceblur

Example with the color scheme you linked:


Well, I compiled it. Then installed it. I’m still not getting the blurred effect. Ever after applying it in the effects.

Did you specify which windows you want to force blur on? It’s in the effect settings, also you must disable the official blur effect

Thank you!! Now I can finally enjoy blurred windows again!

Now, if only your Smart Video Wallpaper would work for AMD users, then I’d finally be set for Plasma 6.

I am the AMD guy who made the issue here: Black screen with gstreamer as Qt Media backend (Recent KDE Neon update) · Issue #8 · luisbocanegra/plasma-smart-video-wallpaper-reborn · GitHub

I can’t get the same effect as you. I have a blur effect. But it’s nowhere near translucent as you have yours. Mine is like very dark when it comes to Dolphin. But Discover looks great.

No much progress on that unfortunately, haven’t had the chance to open the bug report to Qt but will do soon.

Can reproduce after disabling KDE-Rounded-Corners will report it to kwin-effects-forceblur later today or tomorrow.

1 Like

Alright then. And yeah, I don’t have rounded corners set.

I believe it’s a KWin bug. Here’s what it looks like for me on an Intel GPU on Wayland with the blur effect disabled.

Setting the blur strength to maximum helps, but a slightly darker area can still be seen in the middle of the window.

For some reason KDE-Rounded-Corners does fix this even with corner radius and outline thickness set to 0, so you can use that as a workaround for now.

1 Like

Okay. Yeah. That is exactly what happens to me. I think I’ll wait until the bug with KWin is fixed. Because all I see is mostly a dark blur with no translucency. Even with thickness set to 0.

I think I found the reason for the glitching. When using a non-opaque color scheme, KWin doesn’t know that the window is translucent, so it doesn’t paint anything behind it.

I added an option to mark all force-blurred windows as transparent (“Paint windows as non-opaque”) to kwin-effects-forceblur on the develop branch. The fix will unfortunately result in high GPU usage and stuttering if you have a decent amount of unminimized windows open.

Guess I’ll wait until something viable comes around…