Alt and Meta key suddenly swapped when Bluetooth; software or hardware issue?

Hello everybody,

a few days ago, something got confused in my Notebook after I woke it up from sleep. The notebook’s original keyboard unfortunately is not assembled to the screen but has a “cable mode” and “bluetooth mode” (and I think, I switched it before turning the keyboard back on). Everything is fine, when I connect it with cable mode, all keyboard settings work as before. But when I use bluetooth mode, the keyboard behaves strange, which wasn’t like this before.

I noticed changes that the Meta-Key (left “Windows”) and ALT key are swapped and the scroll direction is also inverted. I didn’t notice any other changes.

I don’t know, if this issue is related to KDE settings, some Linux driver or if this could be a firmware issue inside the hardware itself. At least, I didn’t change anything and originally, bluetooth behaved the same as with cable connection.

I tried using the advanced keyboard settings in the KDE settings application but these settings affect the received keyboard input in general. Swapping ALT with (Left) Win will do it for both bluetooth and cable connection.

In Bluetooth mode, when using sudo showkey in the console, the Left Win generates the key code for Left ALT and the Left ALT produces the keycode for Left Win.

Please tell me, if there is a better place to ask. I am using Garuda Linux Dra60nized (uses KDE Plasma).


Okay, I solved my issue by accident and it is actually unrelated to KDE software.

For your information, I am using a very non-mainstream notebook device from a small German manufacturer. The product is called Shift13mi (right, its the same company who produces the ShiftPhones that aim to be more fairly produced).
So, my problem is specific to my device.

It has different modes, a Windows/Linux mode, a Mac mode (where Left Win is swapped with Left Alt) and an Android mode, which is remembered for each connection mode. Apparently, there is a spurious bug where tiling the window to the left (using ALT + LeftArrow), probably after having pressed certain other keys, switches the mode unintensionally. I could temporarily reproduce the glitch multiple times.

It’s easy to fix because there is a function key on the keyboard to swap the mode from Mac mode back to Linux mode.

Regards, Elmar

Hey Elmar,

thanks for coming back and providing the solution to your issue.
Could you also please mark this thread as solved?